]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
GHC 7.0.3 for NetBSD-i386
[pkgsrc-ghc.git] / Makefile
index b9d31283b122d57cba4c898cd1812ffbece4f6f1..f80ff2423ccd9faca50546570285a6fd97b05caf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,11 +11,11 @@ LICENSE=            modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2
 DISTFILES+=            ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
-#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
+DISTFILES+=            ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
 DISTFILES+=            ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 
 
-#SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2    = http://static.cielonegro.org/archive/
+SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2    = http://static.cielonegro.org/archive/
 
@@ -31,15 +31,14 @@ PKG_DESTDIR_SUPPORT=        user-destdir
 #
 # If you want to build HC packages yourself, follow instructions in
 # the ./TODO file.
-#ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
-ONLY_FOR_PLATFORM= FreeBSD-*-i386 Darwin-*-powerpc
+ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
 
 # We must provide the real pass to gcc to the ./configure script,
 # because GHC has a runtime dependency on it. Aren't there any ways
 # better than this?
 .include "../../mk/compiler.mk"
 .if empty(CCPATH)
-WARNINGS+= "This package depends on pkgsrc's undocumented variable\
+WARNINGS+= "This package depends on pkgsrc's undocumented variable \
 CCPATH but it disappeared somehow."
 WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
 CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
@@ -183,7 +182,7 @@ do-configure:
 # Substitutions for INSTALL and DEINSTALL.
 FILES_SUBST+=  DISTNAME=${DISTNAME}
 
-# Some unused scripts don't pass the portability test.
+# There is an unused script which don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
 
 # GHC currently *requires* ${PREFIX}/lib to be in