]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
GHC 7.0.3 for NetBSD-i386
[pkgsrc-ghc.git] / Makefile
index cba47056fe6e7b402e7804ccaae04d98944fe3fd..f80ff2423ccd9faca50546570285a6fd97b05caf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,11 +11,11 @@ LICENSE=            modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2
 DISTFILES+=            ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
-#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
+DISTFILES+=            ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
 DISTFILES+=            ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 
 
-#SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2    = http://static.cielonegro.org/archive/
+SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2    = http://static.cielonegro.org/archive/
 
@@ -31,8 +31,7 @@ PKG_DESTDIR_SUPPORT=  user-destdir
 #
 # If you want to build HC packages yourself, follow instructions in
 # the ./TODO file.
-#ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
-ONLY_FOR_PLATFORM= FreeBSD-*-i386 Darwin-*-powerpc
+ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
 
 # We must provide the real pass to gcc to the ./configure script,
 # because GHC has a runtime dependency on it. Aren't there any ways
@@ -159,7 +158,7 @@ do-configure:
 # in a non-standard path. Without that, the resulting GHC tries to
 # link programs by executing ld(1) without passing it -L${PREFIX}/lib.
        ${RUN} ${ECHO} "libraries/terminfo_CONFIGURE_OPTS += \
-               --configure-option=--with-curses-includes=${PREFIX}/include/ncurses \
+               --configure-option=--with-curses-includes=${PREFIX}/include \
                --configure-option=--with-curses-libraries=${PREFIX}/lib" >> ${WRKSRC}/mk/build.mk
 # The ghc compiler does normally split the generated asm files into small
 # parts before sending them to gcc, to enable the linker to eliminate