]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - TODO
TODO: cosmetic changes
[pkgsrc-ghc.git] / TODO
diff --git a/TODO b/TODO
index f4464bdecd03c360d452e63ca092c349855dbcfe..09d8f934b5d27903d0e3ab39008ce91b4f48bbae 100644 (file)
--- a/TODO
+++ b/TODO
@@ -4,10 +4,17 @@
 wip/ghc TODO
 ============
 
+* Send hunks #3 and #4 of patch-aclocal.m4 to the upstream.
+* Send patch-configure.ac to the upstream.
+* Send patch-libraries-integer-gmp_configure.ac to the upstream.
+* Send patch-rules_hs-suffix-rules-srcdir.mk to the upstream.
+* Modify configure.ac and rules/build-package-data.mk to allow
+  ``--with-curses-{includes,libraries}`` to be passed to the top-level
+  ``configure``, and send a patch to the upstream.
+* Explain about files/bootstrap-main.c and files/capi-wrappers-*.c
+  in this guide, and fix the upstream to throw them away.
 * Build more bootstrapping HC archives to support more platforms.
 
-
---------------------------
 How to build an HC archive
 --------------------------
 
@@ -25,7 +32,6 @@ Extract the source archive and duplicate the source tree, one for
 Build some configuration files::
 
     $ cd ghc-{VERSION}-target
-    $ ln -s /bin/pwd utils/ghc-pwd/ghc-pwd
     $ ./configure --enable-hc-boot
     $ echo "INTEGER_LIBRARY = integer-simple" > mk/build.mk
     $ gmake bootstrapping-files
@@ -34,7 +40,9 @@ Build some configuration files::
 Run ``./configure`` on the host tree::
 
     $ cd ghc-{VERSION}-host
-    $ ./configure
+    $ ./configure \
+          --with-iconv-includes=/usr/pkg/include \
+          --with-iconv-libraries=/usr/pkg/lib
 
 Then create ``ghc-{VERSION}-host/mk/build.mk`` with the following
 contents::
@@ -55,10 +63,14 @@ contents::
     utils/ghc-pkg_dist-install_v_HC_OPTS += -keep-hc-files
     
     INTEGER_LIBRARY = integer-simple
+    libraries/terminfo_CONFIGURE_OPTS += \
+        --configure-option=--with-curses-includes=/usr/pkg/include \
+        --configure-option=--with-curses-libraries=/usr/pkg/lib
 
 Copy some configuration files from the ``-target`` tree::
 
-    $ cp ../ghc-{VERSION}-target/includes/{ghcautoconf.h,DerivedConstants.h,GHCConstants.h} includes/
+    $ cp -r ../ghc-{VERSION}-target/includes/dist-{ghcconstants,derivedconstants} includes/
+    $ cp ../ghc-{VERSION}-target/includes/ghcautoconf.h includes/
 
 Build it::
 
@@ -74,7 +86,7 @@ Create an intermediate tarball::
     $ find . -name package-data.mk >> list
     $ find . -name package.conf.d >> list
     $ find . -name package.conf.inplace >> list
-    $ echo compiler/main/Config.hs >> list
+    $ ls compiler/stage?/build/Config.hs >> list
     $ echo compiler/prelude/primops.txt >> list
     $ ls compiler/primop-*.hs-incl >> list
     $ find . -name .depend | sed -e 's/^/mkdir -p `dirname /' -e 's/$/`/' >> mkfiles
@@ -91,11 +103,15 @@ Then extract it again, in a different directory::
 Modify hard-coded paths in inplace ``.conf`` files, and then
 re-archive the HC tree::
 
-    $ sed -i.bak -e 's#'`dirname \`pwd\``'#[[GHC_SOURCE_PATH]]#g' \
+    $ gsed -i \
+          -e 's#/usr/pkg#[[PREFIX]]#g' \
+          -e 's#'`dirname \`pwd\``'#[[GHC_SOURCE_PATH]]#g' \
           inplace/lib/package.conf.d/*.conf \
+          */package.conf.inplace \
           */*/package-data.mk \
-          */*/*/package-data.mk
+          */*/*/package-data.mk \
+          */*/*/*/package-data.mk
     $ cd ..
-    $ tar jcf ghc-{VERSION}-boot-{PLATFORM}.tar.bz2 ghc-{VERSION}
+    $ tar jcvf ghc-{VERSION}-boot-{PLATFORM}.tar.bz2 ghc-{VERSION}
 
 Done. Upload the archive to some host and add it to the ``Makefile``.