]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - TODO
7.0.1 for powerpc-apple-darwin (but crashes on --interactive)
[pkgsrc-ghc.git] / TODO
diff --git a/TODO b/TODO
index 1bdf6bfec78e9199c110c2ca3e2b8b2734bcb264..5ee5ead1993df8c97eaec2fbdda9d260bb68ecc6 100644 (file)
--- a/TODO
+++ b/TODO
@@ -56,6 +56,10 @@ contents::
     
     INTEGER_LIBRARY = integer-simple
 
+Copy some configuration files from the ``-target`` tree::
+
+    $ cp ../ghc-{VERSION}-target/includes/{ghcautoconf.h,DerivedConstants.h,GHCConstants.h} includes/
+
 Build it::
 
     $ gmake
@@ -70,7 +74,7 @@ Create an intermediate tarball::
     $ find . -name package-data.mk >> list
     $ find . -name package.conf.d >> list
     $ find . -name package.conf.inplace >> list
-    $ echo compiler/main/Config.hs >> list
+    $ ls compiler/stage?/build/Config.hs >> list
     $ echo compiler/prelude/primops.txt >> list
     $ ls compiler/primop-*.hs-incl >> list
     $ find . -name .depend | sed -e 's/^/mkdir -p `dirname /' -e 's/$/`/' >> mkfiles
@@ -92,6 +96,6 @@ re-archive the HC tree::
           */*/package-data.mk \
           */*/*/package-data.mk
     $ cd ..
-    $ tar jcf ghc-{VERSION}-boot-{PLATFORM}.tar.bz2
+    $ tar jcf ghc-{VERSION}-boot-{PLATFORM}.tar.bz2 ghc-{VERSION}
 
 Done. Upload the archive to some host and add it to the ``Makefile``.