]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - TODO
7.0.1 for powerpc-apple-darwin (but crashes on --interactive)
[pkgsrc-ghc.git] / TODO
diff --git a/TODO b/TODO
index 5c89a15fecb40cb3e9ad8b7ebff67eff16951b32..5ee5ead1993df8c97eaec2fbdda9d260bb68ecc6 100644 (file)
--- a/TODO
+++ b/TODO
@@ -74,7 +74,7 @@ Create an intermediate tarball::
     $ find . -name package-data.mk >> list
     $ find . -name package.conf.d >> list
     $ find . -name package.conf.inplace >> list
-    $ echo compiler/main/Config.hs >> list
+    $ ls compiler/stage?/build/Config.hs >> list
     $ echo compiler/prelude/primops.txt >> list
     $ ls compiler/primop-*.hs-incl >> list
     $ find . -name .depend | sed -e 's/^/mkdir -p `dirname /' -e 's/$/`/' >> mkfiles
@@ -96,6 +96,6 @@ re-archive the HC tree::
           */*/package-data.mk \
           */*/*/package-data.mk
     $ cd ..
-    $ tar jcf ghc-{VERSION}-boot-{PLATFORM}.tar.bz2
+    $ tar jcf ghc-{VERSION}-boot-{PLATFORM}.tar.bz2 ghc-{VERSION}
 
 Done. Upload the archive to some host and add it to the ``Makefile``.