]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - TODO
7.0.1 for i386-unknown-netbsd (not tested)
[pkgsrc-ghc.git] / TODO
diff --git a/TODO b/TODO
index 5ee5ead1993df8c97eaec2fbdda9d260bb68ecc6..cc117ccb6b3d5895b7d8824107131a95872c0acf 100644 (file)
--- a/TODO
+++ b/TODO
@@ -34,7 +34,9 @@ Build some configuration files::
 Run ``./configure`` on the host tree::
 
     $ cd ghc-{VERSION}-host
-    $ ./configure
+    $ ./configure \
+          --with-iconv-includes=/usr/pkg/include \
+          --with-iconv-libraries=/usr/pkg/lib
 
 Then create ``ghc-{VERSION}-host/mk/build.mk`` with the following
 contents::
@@ -55,6 +57,9 @@ contents::
     utils/ghc-pkg_dist-install_v_HC_OPTS += -keep-hc-files
     
     INTEGER_LIBRARY = integer-simple
+    libraries/terminfo_CONFIGURE_OPTS += \
+        --configure-option=--with-curses-includes=/usr/pkg/include \
+        --configure-option=--with-curses-libraries=/usr/pkg/lib
 
 Copy some configuration files from the ``-target`` tree::
 
@@ -91,7 +96,9 @@ Then extract it again, in a different directory::
 Modify hard-coded paths in inplace ``.conf`` files, and then
 re-archive the HC tree::
 
-    $ sed -i.bak -e 's#'`dirname \`pwd\``'#[[GHC_SOURCE_PATH]]#g' \
+    $ gsed -i.bak \
+          -e 's#/usr/pkg#[[PREFIX]]#g' \
+          -e 's#'`dirname \`pwd\``'#[[GHC_SOURCE_PATH]]#g' \
           inplace/lib/package.conf.d/*.conf \
           */*/package-data.mk \
           */*/*/package-data.mk