]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - TODO
Update the building guide for ghc-7.4.1
[pkgsrc-ghc.git] / TODO
diff --git a/TODO b/TODO
index c8ac429c6d1d0d5158770b968c14fcc7a57504f5..d4c5fdbd6c71d3f3838ea3f71d06cfa7791f8cd4 100644 (file)
--- a/TODO
+++ b/TODO
@@ -25,7 +25,6 @@ Extract the source archive and duplicate the source tree, one for
 Build some configuration files::
 
     $ cd ghc-{VERSION}-target
-    $ ln -s /bin/pwd utils/ghc-pwd/ghc-pwd
     $ ./configure --enable-hc-boot
     $ echo "INTEGER_LIBRARY = integer-simple" > mk/build.mk
     $ gmake bootstrapping-files
@@ -58,12 +57,13 @@ contents::
     
     INTEGER_LIBRARY = integer-simple
     libraries/terminfo_CONFIGURE_OPTS += \
-        --configure-option=--with-curses-includes=/usr/pkg/include/ncurses \
+        --configure-option=--with-curses-includes=/usr/pkg/include \
         --configure-option=--with-curses-libraries=/usr/pkg/lib
 
 Copy some configuration files from the ``-target`` tree::
 
-    $ cp ../ghc-{VERSION}-target/includes/{ghcautoconf.h,DerivedConstants.h,GHCConstants.h} includes/
+    $ cp -r ../ghc-{VERSION}-target/includes/dist-{ghcconstants,derivedconstants} includes/
+    $ cp ../ghc-{VERSION}-target/includes/ghcautoconf.h includes/
 
 Build it::