]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - bootstrap.mk
7.6.2 for x86_64-unknown-netbsd
[pkgsrc-ghc.git] / bootstrap.mk
index e178a9d6b31417da8b6af95d53d5c533db5df602..a3fe3bc9742c15f504d3d45c833a783680b109d8 100644 (file)
 #   Similar to BOOT_ARCHIVE, but "*.tar" not "*.tar.xz".
 #
 .include "../../mk/bsd.prefs.mk"
-.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
-BOOT_ARCHIVE=  ${DISTNAME}-boot-i386-unknown-netbsdelf6.99.1.tar.bz2
-
-.elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
+.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
 BOOT_ARCHIVE=  ${DISTNAME}-boot-i386-unknown-freebsd8.0.tar.bz2
 
+.elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
+BOOT_ARCHIVE=  ${DISTNAME}-boot-i386-unknown-netbsdelf6.99.1.tar.bz2
+
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 BOOT_ARCHIVE=  ${DISTNAME}-boot-powerpc-apple-darwin.tar.xz
 # Existence of libelf makes LeadingUnderscore being "NO", which is
@@ -27,6 +27,9 @@ CONFLICTS+=           libelf-[0-9]*
 .elif ${MACHINE_ARCH} == "x86_64" && ${OPSYS} == "Linux"
 BOOT_ARCHIVE=  ${DISTNAME}-boot-x86_64-unknown-linux-gnu.tar.bz2
 
+.elif ${MACHINE_ARCH} == "x86_64" && ${OPSYS} == "NetBSD"
+BOOT_ARCHIVE=  ${DISTNAME}-boot-x86_64-unknown-netbsd.tar.xz
+
 .else
 PKG_FAIL_REASON+=      "internal error: unsupported platform"
 .endif