]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - bootstrap.mk
7.6.2 for x86_64-unknown-linux
[pkgsrc-ghc.git] / bootstrap.mk
index 5f48c44a509a9a02ec3a1bfedca0cdc9c9ac7eb5..e882ea67fe9d3d58ce9c29b8b3f5f8713123e8ee 100644 (file)
 #   Similar to BOOT_ARCHIVE, but "*.tar" not "*.tar.xz".
 #
 .include "../../mk/bsd.prefs.mk"
-.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
-BOOT_ARCHIVE=  ${DISTNAME}-boot-i386-unknown-netbsdelf6.99.1.tar.bz2
-
-.elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
+.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
 BOOT_ARCHIVE=  ${DISTNAME}-boot-i386-unknown-freebsd8.0.tar.bz2
 
+.elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
+BOOT_ARCHIVE=  ${DISTNAME}-boot-i386-unknown-netbsdelf6.99.1.tar.bz2
+
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 BOOT_ARCHIVE=  ${DISTNAME}-boot-powerpc-apple-darwin.tar.xz
 # Existence of libelf makes LeadingUnderscore being "NO", which is
 # incorrect for this platform. See ${WRKSRC}/aclocal.m4
 # (FP_LEADING_UNDERSCORE)
-CONFLICTS+=            libelf-[0-9]*
+CONFLICTS+=    libelf-[0-9]*
 
 .elif ${MACHINE_ARCH} == "x86_64" && ${OPSYS} == "Linux"
-BOOT_ARCHIVE=  ${DISTNAME}-boot-x86_64-unknown-linux-gnu.tar.bz2
+BOOT_ARCHIVE=  ${DISTNAME}-boot-x86_64-unknown-linux.tar.xz
+
+.elif ${MACHINE_ARCH} == "x86_64" && ${OPSYS} == "NetBSD"
+BOOT_ARCHIVE=  ${DISTNAME}-boot-x86_64-unknown-netbsd.tar.xz
 
 .else
 PKG_FAIL_REASON+=      "internal error: unsupported platform"
@@ -71,9 +74,14 @@ pre-configure:
 bootstrap:
        @${ERROR_MSG} "You have already configured the package in a way\
        that building bootstrapping compiler is impossible."
-       @${FAIL_MSG}  "Run \"${MAKE} clean\" first."
+       @${FAIL_MSG}  "Please run \"${MAKE} clean patch\" first."
+
+.elif !exists(${WRKDIR}/${DISTNAME}/rts/ghc.mk.orig)
+bootstrap:
+       @${FAIL_MSG} "Please run \"${MAKE} patch\" first."
+
 .else
-bootstrap: patch ${WRKDIR}/${BOOT_ARCHIVE}
+bootstrap: ${WRKDIR}/${BOOT_ARCHIVE}
        @${PHASE_MSG} "Done creating" ${WRKDIR}/${BOOT_ARCHIVE}
 
 ${WRKDIR}/lndir: