]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - files/bootstrap-bsd.mk
ghc-7.4.1 for NetBSD/i386
[pkgsrc-ghc.git] / files / bootstrap-bsd.mk
index aa46508b4782e5153b537fe0d9c0461f5a4d6d0d..594217884315cbc582ca14edf41c48a348f603ee 100644 (file)
@@ -19,3 +19,14 @@ utils/ghc-pkg_dist-install_v_EXTRA_CC_OPTS += -L[[PREFIX]]/lib -lm -liconv -luti
 
 SRC_CC_OPTS += -I[[PREFIX]]/include
 INTEGER_LIBRARY = integer-simple
+
+#   Unregisterised stage0 compiler gets too large (.text section being
+# over 64 MiB) without dead-code elimination, exceeding NetBSD/i386's
+# kernel default limitation.
+#   Note that stage1 currently doesn't bloat that much (about 42.6
+# MiB), but when it does we have to append
+# CONF_CC_OPTS_STAGE1="-fdata..." and
+# CONF_GCC_LINKER_OPTS_STAGE1="-Wl,--gc-sections" to CONFIGURE_ENV as
+# well. I guess that's a matter of time :(
+ghc_stage2_v_ALL_CC_OPTS += -fdata-sections -ffunction-sections
+ghc_stage2_v_EXTRA_CC_OPTS += -Wl,--gc-sections