]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - files/bootstrap-bsd.mk
It turned out that gcc -Os was sufficient to reduce the stage0's .text size under...
[pkgsrc-ghc.git] / files / bootstrap-bsd.mk
index 594217884315cbc582ca14edf41c48a348f603ee..6ddd580c2d5b5c9839d718c366df0551374fd702 100644 (file)
@@ -21,12 +21,9 @@ SRC_CC_OPTS += -I[[PREFIX]]/include
 INTEGER_LIBRARY = integer-simple
 
 #   Unregisterised stage0 compiler gets too large (.text section being
-# over 64 MiB) without dead-code elimination, exceeding NetBSD/i386's
-# kernel default limitation.
+# over 64 MiB) without -Os, exceeding NetBSD/i386's kernel default
+# limitation.
 #   Note that stage1 currently doesn't bloat that much (about 42.6
-# MiB), but when it does we have to append
-# CONF_CC_OPTS_STAGE1="-fdata..." and
-# CONF_GCC_LINKER_OPTS_STAGE1="-Wl,--gc-sections" to CONFIGURE_ENV as
-# well. I guess that's a matter of time :(
-ghc_stage2_v_ALL_CC_OPTS += -fdata-sections -ffunction-sections
-ghc_stage2_v_EXTRA_CC_OPTS += -Wl,--gc-sections
+# MiB), but when it does we have to append CONF_CC_OPTS_STAGE1="-Os"
+# to CONFIGURE_ENV as well. I guess that's a matter of time :(
+EXTRA_CC_OPTS += -Os