]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - files/bootstrap-bsd.mk
It turned out that gcc -Os was sufficient to reduce the stage0's .text size under...
[pkgsrc-ghc.git] / files / bootstrap-bsd.mk
index aa46508b4782e5153b537fe0d9c0461f5a4d6d0d..6ddd580c2d5b5c9839d718c366df0551374fd702 100644 (file)
@@ -19,3 +19,11 @@ utils/ghc-pkg_dist-install_v_EXTRA_CC_OPTS += -L[[PREFIX]]/lib -lm -liconv -luti
 
 SRC_CC_OPTS += -I[[PREFIX]]/include
 INTEGER_LIBRARY = integer-simple
+
+#   Unregisterised stage0 compiler gets too large (.text section being
+# over 64 MiB) without -Os, exceeding NetBSD/i386's kernel default
+# limitation.
+#   Note that stage1 currently doesn't bloat that much (about 42.6
+# MiB), but when it does we have to append CONF_CC_OPTS_STAGE1="-Os"
+# to CONFIGURE_ENV as well. I guess that's a matter of time :(
+EXTRA_CC_OPTS += -Os