]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - files/bootstrap-bsd.mk
ghc-7.4.1 for x86_64-unknown-linux
[pkgsrc-ghc.git] / files / bootstrap-bsd.mk
index e621c0a2268cce9a90dbf1d8c9b39be0a940d744..f67e5b9c6551e414e7155a5256a7594f50736e0c 100644 (file)
@@ -1,4 +1,7 @@
+OMIT_PHASE_0 = YES
+OMIT_PHASE_1 = YES
 GHC = false
+GHC_STAGE1 =
 GHC_PKG_INPLACE =
 GHC_CABAL_INPLACE =
 DUMMY_GHC_INPLACE =
@@ -11,8 +14,16 @@ SplitObjs = NO
 GhcWithNativeCodeGen = NO
 GhcWithInterpreter = NO
 GhcWithSMP = NO
-ghc_stage2_v_EXTRA_CC_OPTS += -Llibraries/integer-gmp/gmp -L[[PREFIX]]/lib -lm -liconv -lutil -lrt
-utils/ghc-pkg_dist-install_v_EXTRA_CC_OPTS += -Llibraries/integer-gmp/gmp -L[[PREFIX]]/lib -lm -liconv -lutil -lrt -ltermcap
+ghc_stage2_v_EXTRA_CC_OPTS += -L[[PREFIX]]/lib -lm -liconv -lutil -lrt
+utils/ghc-pkg_dist-install_v_EXTRA_CC_OPTS += -L[[PREFIX]]/lib -lm -liconv -lutil -lrt -lncurses
 
 SRC_CC_OPTS += -I[[PREFIX]]/include
 INTEGER_LIBRARY = integer-simple
+
+#   Unregisterised stage0 compiler gets too large (.text section being
+# over 64 MiB) without -Os, exceeding NetBSD/i386's kernel default
+# limitation.
+#   Note that stage1 currently doesn't bloat that much (about 42.6
+# MiB), but when it does we have to append CONF_CC_OPTS_STAGE0="-Os"
+# to CONFIGURE_ARGS as well. I guess that's a matter of time :(
+EXTRA_CC_OPTS += -Os