]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - files/bootstrap.build.mk
Merge branch 'ghc-7.6.2'
[pkgsrc-ghc.git] / files / bootstrap.build.mk
diff --git a/files/bootstrap.build.mk b/files/bootstrap.build.mk
new file mode 100644 (file)
index 0000000..0155930
--- /dev/null
@@ -0,0 +1,31 @@
+# -*- makefile-gmake -*-
+#
+# This is a build conf for bootstrapping compilers.
+#
+
+# We don't want any docs.
+HADDOCK_DOCS       = NO
+BUILD_DOCBOOK_HTML = NO
+BUILD_DOCBOOK_PS   = NO
+BUILD_DOCBOOK_PDF  = NO
+BUILD_MAN          = NO
+
+# Enabling evil-splitter reduces bindist size, which is good. However
+# it introduces a run-time dependency on perl, which is unacceptable.
+SplitObjs          = NO
+
+# We only want vanilla libraries and rts. No profiling, no shared
+# libraries, no debugging, no event logging.
+GhcLibWays         = v
+GhcRTSWays         =
+
+# I'm not sure disabling GHCi significantly reduces the bindist size,
+# but we don't need it anyway.
+GhcWithInterpreter = NO
+
+# We don't want in-place GMP to be statically linked as it increases
+# the bindist size. Dynamic linkage is even worse.
+INTEGER_LIBRARY    = integer-simple
+
+# We'd like to distinguish bootstrapping bindists from normal ones.
+BIN_DIST_NAME      = ghc-$(ProjectVersion)-boot