]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - patches/patch-ab
7.0.1 for powerpc-apple-darwin (but crashes on --interactive)
[pkgsrc-ghc.git] / patches / patch-ab
index 4bed7ba1a81768fc1cb7b4e9ae8929d6aff5c912..864fccc4f12b8e753770e83cc1d916ce12e9bd9d 100644 (file)
@@ -1,21 +1,29 @@
-$NetBSD: patch-ab,v 1.8 2007/03/24 17:57:20 kristerw Exp $
+$NetBSD$
 
---- ../ghc-6.4.2/mk/bootstrap.mk.orig  2005-05-10 19:42:19.000000000 +0900
-+++ ../ghc-6.4.2/mk/bootstrap.mk
-@@ -37,7 +37,6 @@ PLATFORM_CC_OPTS += -static -D_HPUX_SOUR
- endif
+--- configure.orig     2010-11-12 18:10:41.000000000 +0000
++++ configure
+@@ -6181,7 +6181,7 @@ fi
  
- ifeq "$(powerpc_TARGET_ARCH)" "1"
--PLATFORM_CC_OPTS += -static
- PLATFORM_HC_BOOT_CC_OPTS += -finhibit-size-directive
- endif
  
-@@ -146,7 +145,7 @@ HC_BOOT_LD_OPTS += \
- HC_BOOT_LIBS =
+ if test -n "$DtraceCmd"; then
+-  if test "x$TargetOS_CPP-$TargetVendor_CPP" == "xdarwin-apple"; then
++  if test "x$TargetOS_CPP-$TargetVendor_CPP" = "xdarwin-apple"; then
+     HaveDtrace=YES
+   fi
+ fi
+@@ -6507,6 +6507,7 @@ $as_echo "$as_me: WARNING: cannot find h
+ fi
++if test "$BootingFromHc" = "NO"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for ghc-pkg matching $WithGhc" >&5
+ $as_echo_n "checking for ghc-pkg matching $WithGhc... " >&6; }
+ if test "${fp_cv_matching_ghc_pkg+set}" = set; then :
+@@ -6528,6 +6529,7 @@ fi
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $fp_cv_matching_ghc_pkg" >&5
+ $as_echo "$fp_cv_matching_ghc_pkg" >&6; }
+ GhcPkgCmd=$fp_cv_matching_ghc_pkg
++fi
  
- ifeq "$(GhcWithInterpreter)" "YES"
--HC_BOOT_LIBS += -lHSreadline -lHStemplate-haskell -lHSunix -lHSunix_cbits
-+HC_BOOT_LIBS += -lHStemplate-haskell -lHSunix -lHSunix_cbits
- endif
  
- HC_BOOT_LIBS +=  -lHSCabal -lHShaskell98 -lHSbase -lHSbase_cbits -lHSparsec -lHSrts -lgmp -lm $(EXTRA_HC_BOOT_LIBS)