]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - patches/patch-rts_ghc.mk
7.6.2 for powerpc-apple-darwin
[pkgsrc-ghc.git] / patches / patch-rts_ghc.mk
index 5402cec289c4464f7c516ca8bcb5356d71dfa029..78eb21cdec0f1b379eaa4e76105a6f81ca08017e 100644 (file)
@@ -1,38 +1,17 @@
 $NetBSD$
 
-Hunk #1:
-  Specify a C compiler to build C sources when we're bootstrapping.
+This is pkgsrc specific: dtrace(1) gets confused when we have gcc
+wrappers in the PATH so we have to hide them:
 
-Hunk #2:
-  Missing dependency on generated headers.
+  gcc: installation problem, cannot exec '/usr/pkgsrc/wip/ghc/work/.gcc/bin/p
+  owerpc-apple-darwin9-gcc-4.0.1': No such file or directory
+  dtrace: failed to compile script rts/RtsProbes.d: Preprocessor failed to pr
+  ocess input program
 
-Hunk #3:
-  This is pkgsrc specific: /usr/sbin/dtrace gets confused when we have
-  ghc wrappers in the PATH so we have to hide them.
 
-
---- rts/ghc.mk.orig    2012-02-01 18:10:32.000000000 +0000
+--- rts/ghc.mk.orig    2013-01-27 13:21:52.000000000 +0000
 +++ rts/ghc.mk
-@@ -15,6 +15,7 @@
- # We build the RTS with stage 1
- rts_dist_HC = $(GHC_STAGE1)
-+rts_dist_CC = $(CC_STAGE1)
- # merge GhcLibWays and GhcRTSWays but strip out duplicates
- rts_WAYS = $(GhcLibWays) $(filter-out $(GhcLibWays),$(GhcRTSWays))
-@@ -457,6 +458,10 @@ $(eval $(call dependencies,rts,dist,1))
- $(rts_dist_depfile_c_asm) : $(libffi_HEADERS) $(DTRACEPROBES_H)
-+ifeq "$(BootingFromHc)" "YES"
-+$(rts_C_SRCS) : $(libffi_HEADERS) $(DTRACEPROBES_H)
-+endif
-+
- # -----------------------------------------------------------------------------
- # compile dtrace probes if dtrace is supported
-@@ -479,7 +484,7 @@ endif
+@@ -484,7 +484,7 @@ endif
  
  DTRACEPROBES_SRC = rts/RtsProbes.d
  $(DTRACEPROBES_H): $(DTRACEPROBES_SRC) includes/ghcplatform.h | $$(dir $$@)/.