]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - patches/patch-rts_ghc.mk
7.6.2 for powerpc-apple-darwin
[pkgsrc-ghc.git] / patches / patch-rts_ghc.mk
index bb7d3b22fb77dc8c4f9d07abe65129393a63968e..78eb21cdec0f1b379eaa4e76105a6f81ca08017e 100644 (file)
@@ -1,38 +1,22 @@
 $NetBSD$
 
-The first section:
-  HC bootstrapping has bitrotted further. We need to build RtsProbes.h
-  before compiling Capability.hc but rts/ghc.mk doesn't have such
-  rule.
+This is pkgsrc specific: dtrace(1) gets confused when we have gcc
+wrappers in the PATH so we have to hide them:
 
-The second section:
-  This is pkgsrc specific. /usr/sbin/dtrace gets confused when we have
-  ghc wrappers in the PATH so we have to hide them.
+  gcc: installation problem, cannot exec '/usr/pkgsrc/wip/ghc/work/.gcc/bin/p
+  owerpc-apple-darwin9-gcc-4.0.1': No such file or directory
+  dtrace: failed to compile script rts/RtsProbes.d: Preprocessor failed to pr
+  ocess input program
 
 
---- rts/ghc.mk.orig    2011-03-26 18:10:07.000000000 +0000
+--- rts/ghc.mk.orig    2013-01-27 13:21:52.000000000 +0000
 +++ rts/ghc.mk
-@@ -452,12 +452,14 @@ rts_dist_MKDEPENDC_OPTS += -DPROFILING -
- ifeq "$(USE_DTRACE)" "YES"
- rts_dist_MKDEPENDC_OPTS += -Irts/dist/build
-+rts_CC_OPTS += -Irts/dist/build
- endif
- $(eval $(call build-dependencies,rts,dist,1))
- $(rts_dist_depfile_c_asm) : libffi/dist-install/build/ffi.h $(DTRACEPROBES_H)
-+rts/dist/build/Capability.o : $(DTRACEPROBES_H)
- #-----------------------------------------------------------------------------
- # libffi stuff
-@@ -489,7 +491,7 @@ endif
+@@ -484,7 +484,7 @@ endif
  
  DTRACEPROBES_SRC = rts/RtsProbes.d
  $(DTRACEPROBES_H): $(DTRACEPROBES_SRC) includes/ghcplatform.h | $$(dir $$@)/.
 -      "$(DTRACE)" $(filter -I%,$(rts_CC_OPTS)) -C $(DTRACE_FLAGS) -h -o $@ -s $<
-+      env PATH=/usr/bin "$(DTRACE)" $(filter -I%,$(rts_CC_OPTS)) -C $(DTRACE_FLAGS) -h -o $@ -s $<
++      env PATH="/usr/bin" "$(DTRACE)" $(filter -I%,$(rts_CC_OPTS)) -C $(DTRACE_FLAGS) -h -o $@ -s $<
  endif
  
  # -----------------------------------------------------------------------------