]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - stage0.mk
It turned out that gcc -Os was sufficient to reduce the stage0's .text size under...
[pkgsrc-ghc.git] / stage0.mk
index ca962442f2640ca9260c5ca6e8c002dd02699606..d66415a9777d0c45a0c89021bf65e469507ef224 100644 (file)
--- a/stage0.mk
+++ b/stage0.mk
@@ -75,21 +75,7 @@ ${WRKDIR}/stamp-extract-hc: ${WRKDIR}/stamp-configure-hc-boot
 ${WRKDIR}/stamp-rewrite-hc-paths: ${WRKDIR}/stamp-extract-hc
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
                ${PHASE_MSG} "Rewriting source paths in bootstrapping compiler for ${PKGNAME}" && \
-               ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk
-.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
-#   Unregisterised stage0 compiler gets too large (.text section being
-# over 64 MiB) without dead-code elimination, exceeding NetBSD/i386's
-# kernel default limitation.
-#   Note that stage1 currently doesn't bloat that much (about 42.6
-# MiB), but when it does we have to append
-# CONF_CC_OPTS_STAGE1="-fdata..." and
-# CONF_GCC_LINKER_OPTS_STAGE1="-Wl,--gc-sections" to CONFIGURE_ENV as
-# well. I guess that's a matter of time :(
-       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
-               ${ECHO} "EXTRA_CC_OPTS += -fdata-sections -ffunction-sections" >> mk/build.mk && \
-               ${ECHO} "EXTRA_CC_OPTS += -Wl,--gc-sections" >> mk/build.mk
-.endif
-       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
+               ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \