]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
It finally works on NetBSD/i386.
authorPHO <pho@cielonegro.org>
Tue, 22 Dec 2009 07:14:39 +0000 (16:14 +0900)
committerPHO <pho@cielonegro.org>
Tue, 22 Dec 2009 07:14:39 +0000 (16:14 +0900)
Makefile

index a6a77b8294882aa0ecb21257ae123456914d7bba..a647d2668760f672707115d1a6f055e38e4a950e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -10,25 +10,20 @@ COMMENT=            Compiler for the functional language Haskell
 LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
 LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
-                               ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2 \
-                               ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
+                               ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2 \
+                               ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
 
 SITES.${DISTNAME}-src.tar.bz2                                          = http://www.haskell.org/ghc/dist/${VERSION}/
 
 SITES.${DISTNAME}-src.tar.bz2                                          = http://www.haskell.org/ghc/dist/${VERSION}/
-SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
 SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
+SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
 
 PKG_DESTDIR_SUPPORT=   user-destdir
 
 
 PKG_DESTDIR_SUPPORT=   user-destdir
 
-# PLIST cannot be generated statically because of hashed package
-# config files. This requires USE_DESTDIR=yes.
-PLIST_TYPE = dynamic
-
 .include "../../mk/bsd.prefs.mk"
 
 # Unregisterised HC packages are architecture dependent. We have to
 # create more HC packages to support more architectures.
 .include "../../mk/bsd.prefs.mk"
 
 # Unregisterised HC packages are architecture dependent. We have to
 # create more HC packages to support more architectures.
-#ONLY_FOR_PLATFORM= *-*-i386 *-*-powerpc
-ONLY_FOR_PLATFORM= *-*-i386
+ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386
 
 USE_TOOLS+=    gmake bsdtar perl:run
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
 
 USE_TOOLS+=    gmake bsdtar perl:run
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
@@ -53,20 +48,20 @@ CONFIGURE_ARGS += \
 # "${BUILDLINK_DIR}/bin". Note that in-place ghc isn't usable before
 # running "ghc-pkg recache".
 
 # "${BUILDLINK_DIR}/bin". Note that in-place ghc isn't usable before
 # running "ghc-pkg recache".
 
-.if ${MACHINE_ARCH} == "i386"
-.  if ${OPSYS} == "FreeBSD"
+.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
+BOOTSTRAP_TARBALL  = ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
+BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+
+.elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
 BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
 BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
-.  else
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
-.  endif
-#.elif ${MACHINE_ARCH} == "powerpc"
+BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+
+#.elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 #BOOTSTRAP_TARBALL = ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 #BOOTSTRAP_TARBALL = ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
-.endif
+#BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
 
 
-.if ${OPSYS} == "NetBSD" || ${OPSYS} == "DragonFly" || ${OPSYS} == "FreeBSD" || ${OPSYS} == "OpenBSD"
-BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
 .else
 .else
-BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
+PKG_FAIL_REASON+=      "internal error: unsupported platform"
 .endif
 
 pre-configure:
 .endif
 
 pre-configure: