]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
Use autotools' idea of the canonical name of platform as-is.
authorPHO <pho@cielonegro.org>
Thu, 23 Feb 2012 13:44:34 +0000 (22:44 +0900)
committerPHO <pho@cielonegro.org>
Thu, 23 Feb 2012 13:44:34 +0000 (22:44 +0900)
Makefile
distinfo

index 44485c26cb123bc27bab2833415b106a9185e207..19c0a9cbfca3ebd4a8d51f5237729956c053aa68 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -10,18 +10,16 @@ COMMENT=            Compiler for the functional language Haskell
 LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2
-DISTFILES+=            ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
-#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
-DISTFILES+=            ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
+DISTFILES+=            ${DISTNAME}-boot-i386-unknown-freebsd8.0.tar.bz2
+#DISTFILES+=           ${DISTNAME}-boot-i386-unknown-netbsdelf6.99.1.tar.bz2
+DISTFILES+=            ${DISTNAME}-boot-powerpc-apple-darwin9.8.0.tar.bz2
 
-SITES.${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2     = http://static.cielonegro.org/archive/
-SITES.${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2    = http://static.cielonegro.org/archive/
-SITES.${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2    = http://static.cielonegro.org/archive/
+.for i in ${DISTFILES:M*-boot-*}
+SITES.${i}=            http://static.cielonegro.org/archive/
+.endfor
 
 PKG_DESTDIR_SUPPORT=   user-destdir
 
-.include "../../mk/bsd.prefs.mk"
-
 # Unregisterised HC packages are architecture dependent. We have to
 # create more HC packages to support more architectures. Note that
 # these packages are built with integer-simple, not integer-gmp, to
@@ -35,6 +33,7 @@ ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
 # We must provide the real pass to gcc to the ./configure script,
 # because GHC has a runtime dependency on it. Aren't there any ways
 # better than this?
+.include "../../mk/bsd.prefs.mk"
 .include "../../mk/compiler.mk"
 .if empty(CCPATH)
 WARNINGS+= "This package depends on pkgsrc's undocumented variable \
@@ -68,23 +67,23 @@ CONFIGURE_ARGS += \
 #
 # To install it, we just copy ghc and ghc-pkg from
 # "work/bootstrap/ghc-${VERSION}/inplace/bin" to
-# "${BUILDLINK_DIR}/bin". Note that in-place ghc isn't usable before
-# running "ghc-pkg recache".
+# "${BUILDLINK_DIR}/bin". Note that in-place ghc isn't usable until we
+# run "ghc-pkg recache".
 
 .if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
 BOOTSTRAP_CAPI_C   = ${PKGDIR}/files/capi-wrappers-netbsd-i386.c
-PLATFORM           = i386-unknown-netbsd
+PLATFORM           = i386-unknown-netbsdelf6.99.1
 
 .elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
 BOOTSTRAP_CAPI_C   = ${PKGDIR}/files/capi-wrappers-freebsd-i386.c
-PLATFORM           = i386-unknown-freebsd
+PLATFORM           = i386-unknown-freebsd8.0
 
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
 BOOTSTRAP_CAPI_C   = ${PKGDIR}/files/capi-wrappers-darwin-powerpc.c
-PLATFORM           = powerpc-apple-darwin
+PLATFORM           = powerpc-apple-darwin9.8.0
 # Existence of libelf makes LeadingUnderscore being "NO", which is
 # incorrect for this platform. See ghc-6.12.1/aclocal.m4
 # (FP_LEADING_UNDERSCORE)
index b1374d8a68b85735b65f0162c0f089ff75158c13..9245de8a19d0848da81b27384c136d1219f9a820 100644 (file)
--- a/distinfo
+++ b/distinfo
@@ -1,11 +1,11 @@
 $NetBSD$
 
-SHA1 (ghc-7.4.1-boot-i386-unknown-freebsd.tar.bz2) = ecc5b1469f20ffd2dd49b201711519ed91bca280
-RMD160 (ghc-7.4.1-boot-i386-unknown-freebsd.tar.bz2) = 3306d8a0e1c7510598b7ac2ef1a6b6e640823258
-Size (ghc-7.4.1-boot-i386-unknown-freebsd.tar.bz2) = 26476045 bytes
-SHA1 (ghc-7.4.1-boot-powerpc-apple-darwin.tar.bz2) = 0165e30fb357ff487afa3b31d9eac5d8ea3374fe
-RMD160 (ghc-7.4.1-boot-powerpc-apple-darwin.tar.bz2) = 35340e832a6202949c35c72492dff8185b1e852c
-Size (ghc-7.4.1-boot-powerpc-apple-darwin.tar.bz2) = 26636237 bytes
+SHA1 (ghc-7.4.1-boot-i386-unknown-freebsd8.0.tar.bz2) = ecc5b1469f20ffd2dd49b201711519ed91bca280
+RMD160 (ghc-7.4.1-boot-i386-unknown-freebsd8.0.tar.bz2) = 3306d8a0e1c7510598b7ac2ef1a6b6e640823258
+Size (ghc-7.4.1-boot-i386-unknown-freebsd8.0.tar.bz2) = 26476045 bytes
+SHA1 (ghc-7.4.1-boot-powerpc-apple-darwin9.8.0.tar.bz2) = 0165e30fb357ff487afa3b31d9eac5d8ea3374fe
+RMD160 (ghc-7.4.1-boot-powerpc-apple-darwin9.8.0.tar.bz2) = 35340e832a6202949c35c72492dff8185b1e852c
+Size (ghc-7.4.1-boot-powerpc-apple-darwin9.8.0.tar.bz2) = 26636237 bytes
 SHA1 (ghc-7.4.1-src.tar.bz2) = 66c5a027fef1ed01c35c3493e964fb3657efc936
 RMD160 (ghc-7.4.1-src.tar.bz2) = 00c6a4df54e55559812b0e289dbc6fe8523d18da
 Size (ghc-7.4.1-src.tar.bz2) = 25272609 bytes