]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
-perm -o+x
authorPHO <pho@cielonegro.org>
Tue, 24 Feb 2009 06:09:39 +0000 (15:09 +0900)
committerPHO <pho@cielonegro.org>
Tue, 24 Feb 2009 06:09:39 +0000 (15:09 +0900)
Makefile

index 691fb8b9b0e99dff0d4df0f833d387113f688d30..f178a5c164156cef875629079ed2e102d847f1ca 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -49,7 +49,7 @@ pre-configure:
        cd ${WRKDIR}/ghc-6.6.1 && \
                ${CHMOD} +x ./distrib/hc-build && \
                ${ENV} ${CONFIGURE_ENV} ./distrib/hc-build -C --disable-readline --enable-hc-boot-unregisterised && \
        cd ${WRKDIR}/ghc-6.6.1 && \
                ${CHMOD} +x ./distrib/hc-build && \
                ${ENV} ${CONFIGURE_ENV} ./distrib/hc-build -C --disable-readline --enable-hc-boot-unregisterised && \
-               ${FIND} . -type f -and -perm +o+x -and -name '*-inplace' | \
+               ${FIND} . -type f -and -perm -o+x -and -name '*-inplace' | \
                        while read i; do \
                                ${CP} $$i ${BUILDLINK_DIR}/bin/`basename $$i | sed -e 's/-inplace//'`; \
                        done
                        while read i; do \
                                ${CP} $$i ${BUILDLINK_DIR}/bin/`basename $$i | sed -e 's/-inplace//'`; \
                        done