]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
Fix: ghc-asm fails when PLATFORM=powerpc-unknown-darwin
authorPHO <pho@cielonegro.org>
Fri, 22 Jan 2010 09:03:11 +0000 (18:03 +0900)
committerPHO <pho@cielonegro.org>
Fri, 22 Jan 2010 09:03:11 +0000 (18:03 +0900)
Makefile

index 399d09d818d8316ef60c0b5f16dcd655571ebc4f..9d18724639e1c6e519982dd1eae845d09770b3e1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -49,7 +49,6 @@ CONFIGURE_ENV+=               PerlCmd=${PERL5:Q}
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
-PLATFORM= ${MACHINE_ARCH}-unknown-${LOWER_OPSYS}
 CONFIGURE_ARGS += \
        --build=${PLATFORM} \
        --host=${PLATFORM} \
 CONFIGURE_ARGS += \
        --build=${PLATFORM} \
        --host=${PLATFORM} \
@@ -71,16 +70,17 @@ CONFIGURE_ARGS += \
 # running "ghc-pkg recache".
 
 .if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
 # running "ghc-pkg recache".
 
 .if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
-BOOTSTRAP_TARBALL  = ${DISTNAME}-boot-i386-unknown-netbsd.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+PLATFORM           = i386-unknown-netbsd
 
 .elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
 
 .elif ${MACHINE_ARCH} == "i386" && ${OPSYS} == "FreeBSD"
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-i386-unknown-freebsd.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-bsd.mk
+PLATFORM           = i386-unknown-freebsd
 
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
 
 .elif ${MACHINE_ARCH} == "powerpc" && ${OPSYS} == "Darwin"
-BOOTSTRAP_TARBALL = ${DISTNAME}-boot-powerpc-apple-darwin.tar.bz2
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
 BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap.mk
+PLATFORM           = powerpc-apple-darwin
+
 # Existence of libelf makes LeadingUnderscore being "NO", which is
 # incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
 CONFLICTS=     libelf-[0-9]*
 # Existence of libelf makes LeadingUnderscore being "NO", which is
 # incorrect. See ghc-6.12.1/aclocal.m4 (FP_LEADING_UNDERSCORE)
 CONFLICTS=     libelf-[0-9]*
@@ -89,6 +89,8 @@ CONFLICTS=    libelf-[0-9]*
 PKG_FAIL_REASON+=      "internal error: unsupported platform"
 .endif
 
 PKG_FAIL_REASON+=      "internal error: unsupported platform"
 .endif
 
+BOOTSTRAP_TARBALL = ${DISTNAME}-boot-${PLATFORM}.tar.bz2
+
 pre-configure:
        ${RUN} cd ${WRKDIR} && \
                ${ECHO} "====> Preparing bootstrap compiler" && \
 pre-configure:
        ${RUN} cd ${WRKDIR} && \
                ${ECHO} "====> Preparing bootstrap compiler" && \