]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
Fixed Makefile bug
authorPHO <pho@cielonegro.org>
Fri, 25 Dec 2009 06:45:44 +0000 (15:45 +0900)
committerPHO <pho@cielonegro.org>
Fri, 25 Dec 2009 06:45:44 +0000 (15:45 +0900)
Makefile

index dbe893ed11387e7536a35466ff2a0170e7670b67..e0e6201fcb5d02b2a17d1c59fb7c5fc7a97ec2fa 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -45,13 +45,27 @@ CONFIGURE_ENV+=             PerlCmd=${PERL5:Q}
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
+<<<<<<< Makefile
+PLATFORM= ${LOWER_ARCH}-unknown-${LOWER_OPSYS}
 CONFIGURE_ARGS += \
+       --build=${PLATFORM} \
+       --host=${PLATFORM} \
+       --target=${PLATFORM} \
        --prefix=${PREFIX} \
        --mandir=${PREFIX}/${PKGMANDIR} \
        --with-gmp-includes=${PREFIX}/include \
        --with-gmp-libraries=${PREFIX}/lib \
        --with-iconv-includes=${PREFIX}/include \
        --with-iconv-libraries=${PREFIX}/lib
+=======
+CONFIGURE_ARGS += \
+       --prefix=${PREFIX} \
+       --mandir=${PREFIX}/${PKGMANDIR} \
+       --with-gmp-includes=${PREFIX}/include \
+       --with-gmp-libraries=${PREFIX}/lib \
+       --with-iconv-includes=${PREFIX}/include \
+       --with-iconv-libraries=${PREFIX}/lib
+>>>>>>> 1.14
 
 # Build an unregisterised bootstrap compiler and install it directly
 # into the .buildlink directory. But we can't use "make install"