]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
Fixed a problem with libgmp in a non-standard path.
authorPHO <pho@cielonegro.org>
Thu, 2 Jul 2009 08:54:30 +0000 (17:54 +0900)
committerPHO <pho@cielonegro.org>
Thu, 2 Jul 2009 08:54:30 +0000 (17:54 +0900)
Makefile

index eec39d83cb2020c5c3105b90f5da4e42e2712094..f54ed3748edb8c0701478018545e6c3af9c9acda 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -7,6 +7,7 @@ MASTER_SITES=   http://www.haskell.org/ghc/dist/${VERSION}/
 MAINTAINER=            kristerw@NetBSD.org
 HOMEPAGE=              http://www.haskell.org/ghc/
 COMMENT=               Compiler for the functional language Haskell
 MAINTAINER=            kristerw@NetBSD.org
 HOMEPAGE=              http://www.haskell.org/ghc/
 COMMENT=               Compiler for the functional language Haskell
+LICENSE=               modified-bsd
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
                                ghc-6.6.1-src.tar.bz2 \
 
 DISTFILES=             ${DISTNAME}-src.tar.bz2 \
                                ghc-6.6.1-src.tar.bz2 \
@@ -39,6 +40,12 @@ EXTRACT_ONLY += ghc-6.6.1-i386-unknown-freebsd-hc.tar.gz
 EXTRACT_ONLY += ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz
 .endif
 
 EXTRACT_ONLY += ghc-6.6.1-powerpc-apple-darwin-hc.tar.gz
 .endif
 
+# We need to tell the ./configure that libgmp is in a non-standard path. Without
+# that, the resulting GHC tries to link programs by executing ld(1) without
+# passing it -L${PREFIX}/lib.
+CONFIGURE_ARGS += --with-gmp-includes=${PREFIX}/include
+CONFIGURE_ARGS += --with-gmp-libraries=${PREFIX}/lib
+
 # Build an unregisterised bootstrap compiler and install it directly
 # into the .buildlink directory. But we can't use "make install"
 # because we don't build it in a standard way (./configure && make).
 # Build an unregisterised bootstrap compiler and install it directly
 # into the .buildlink directory. But we can't use "make install"
 # because we don't build it in a standard way (./configure && make).