]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
patch for Linker.c
authorPHO <pho@cielonegro.org>
Sun, 2 May 2010 13:09:13 +0000 (22:09 +0900)
committerPHO <pho@cielonegro.org>
Sun, 2 May 2010 13:09:13 +0000 (22:09 +0900)
distinfo
patches/patch-ag [new file with mode: 0644]

index 87f06b03b5fa775d903028d15a59615612dd941b..5a3c12935e3121c7e3afc76157a5a949251d456c 100644 (file)
--- a/distinfo
+++ b/distinfo
@@ -7,4 +7,5 @@ SHA1 (ghc-6.12.2-src.tar.bz2) = 421967729beab8a5051b8b7c216240bfcb879c84
 RMD160 (ghc-6.12.2-src.tar.bz2) = ad114022420fbb313dc56f1c5285d1cef4c88f2f
 Size (ghc-6.12.2-src.tar.bz2) = 34158695 bytes
 SHA1 (patch-af) = 81ae37eeaca5992868f6955b99113aaae010df22
+SHA1 (patch-ag) = 96c074d0d765c0f2de57d26aa145ad109b7cf043
 SHA1 (patch-ah) = 5470ab2e1bb746ef3009e5f02ac0b28b8e9d9688
diff --git a/patches/patch-ag b/patches/patch-ag
new file mode 100644 (file)
index 0000000..f5021b0
--- /dev/null
@@ -0,0 +1,14 @@
+$NetBSD$
+
+--- rts/Linker.c.orig  2010-04-20 18:10:07.000000000 +0000
++++ rts/Linker.c
+@@ -4122,7 +4122,8 @@ static int relocateSection(
+                   else if(scat->r_type == PPC_RELOC_SECTDIFF
+                       || scat->r_type == PPC_RELOC_LO16_SECTDIFF
+                       || scat->r_type == PPC_RELOC_HI16_SECTDIFF
+-                      || scat->r_type == PPC_RELOC_HA16_SECTDIFF)
++                      || scat->r_type == PPC_RELOC_HA16_SECTDIFF
++                      || scat->r_type == PPC_RELOC_LOCAL_SECTDIFF)
+ #else
+                     else if(scat->r_type == GENERIC_RELOC_SECTDIFF
+                         || scat->r_type == GENERIC_RELOC_LOCAL_SECTDIFF)