]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
It finally passes developer's tests on FreeBSD!
authorPHO <pho@cielonegro.org>
Fri, 18 Dec 2009 00:28:21 +0000 (09:28 +0900)
committerPHO <pho@cielonegro.org>
Fri, 18 Dec 2009 00:28:21 +0000 (09:28 +0900)
Makefile
PLIST

index 9164300fcf9267087b302e08d1afdc526f5eaa27..3fc3d82e8f879cc7792f161cfaeb63fd3a26264d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,17 +24,15 @@ PKG_DESTDIR_SUPPORT=        user-destdir
 #ONLY_FOR_PLATFORM= *-*-i386 *-*-powerpc
 ONLY_FOR_PLATFORM= *-*-i386
 
 #ONLY_FOR_PLATFORM= *-*-i386 *-*-powerpc
 ONLY_FOR_PLATFORM= *-*-i386
 
-USE_TOOLS+=    gmake bsdtar perl
+USE_TOOLS+=    gmake bsdtar perl:run
+CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
 
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
 
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
-# We need to tell the ./configure that libgmp is in a non-standard path. Without
-# that, the resulting GHC tries to link programs by executing ld(1) without
-# passing it -L${PREFIX}/lib.
 CONFIGURE_ARGS += \
        --prefix=${PREFIX} \
 CONFIGURE_ARGS += \
        --prefix=${PREFIX} \
-       --mandir=${PKGMANDIR} \
+       --mandir=${PREFIX}/${PKGMANDIR} \
        --with-gmp-includes=${PREFIX}/include \
        --with-gmp-libraries=${PREFIX}/lib \
        --with-iconv-includes=${PREFIX}/include \
        --with-gmp-includes=${PREFIX}/include \
        --with-gmp-libraries=${PREFIX}/lib \
        --with-iconv-includes=${PREFIX}/include \
@@ -74,7 +72,7 @@ pre-configure:
                (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
                ${SH} mkfiles && \
                ${ECHO} "====> Building bootstrap compiler" && \
                (cd .. && bsdtar jxfm ${DISTDIR}/${BOOTSTRAP_TARBALL}) && \
                ${SH} mkfiles && \
                ${ECHO} "====> Building bootstrap compiler" && \
-               ${SED} -e 's#\\[\\[PREFIX\\]\\]#${PREFIX}#g' ${BUILD_MK} > mk/build.mk && \
+               ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BUILD_MK} > mk/build.mk && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${ENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${ENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \
@@ -89,9 +87,15 @@ pre-configure:
                ${CP} inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
                ${CP} inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg
 
                ${CP} inplace/bin/ghc-stage2 ${BUILDLINK_DIR}/bin/ghc && \
                ${CP} inplace/bin/ghc-pkg ${BUILDLINK_DIR}/bin/ghc-pkg
 
+# We need to tell the libraries/integer-gmp/configure that libgmp is
+# in a non-standard path. Without that, the resulting GHC tries to
+# link programs by executing ld(1) without passing it -L${PREFIX}/lib.
 do-configure:
        ${RUN} cd ${WRKSRC} && \
                ${ENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
 do-configure:
        ${RUN} cd ${WRKSRC} && \
                ${ENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS}
+       ${RUN} ${ECHO} "libraries/integer-gmp_CONFIGURE_OPTS += \
+               --configure-option=--with-gmp-includes=${PREFIX}/include \
+               --configure-option=--with-gmp-libraries=${PREFIX}/lib" > ${WRKSRC}/mk/build.mk
 
 # The ghc compiler does normally split the generated C files into small
 # parts before sending them to gcc, to enable the linker to eliminate
 
 # The ghc compiler does normally split the generated C files into small
 # parts before sending them to gcc, to enable the linker to eliminate
@@ -102,11 +106,16 @@ do-configure:
 # for a description of the problem.
 # Disable file splitting until pkgsrc gets improved.
 pre-build:
 # for a description of the problem.
 # Disable file splitting until pkgsrc gets improved.
 pre-build:
-       ${ECHO} "SplitObjs=NO" > ${WRKSRC}/mk/build.mk
+       ${RUN} ${ECHO} "SplitObjs = NO" >> ${WRKSRC}/mk/build.mk
 
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
 
 
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw
 
+# GHC currently *requires* ${PREFIX}/lib to be in
+# "/etc/ld-elf.so.conf". See
+# http://hackage.haskell.org/trac/ghc/ticket/2933
+CHECK_SHLIBS_SUPPORTED=        no
+
 BUILDLINK_DEPMETHOD.libxslt = build
 .include "../../converters/libiconv/buildlink3.mk"
 .include "../../devel/gmp/buildlink3.mk"
 BUILDLINK_DEPMETHOD.libxslt = build
 .include "../../converters/libiconv/buildlink3.mk"
 .include "../../devel/gmp/buildlink3.mk"
diff --git a/PLIST b/PLIST
index c68dd45b8f021c2914c3d59d707b8e4f23b86c1b..5e3fcbb257238942c924609781949e1dcc82da1a 100644 (file)
--- a/PLIST
+++ b/PLIST
@@ -2004,7 +2004,7 @@ lib/${PKGNAME}/package.conf.d/dph-prim-seq-0.4.0-23150bc82f21bd4268b1551af7a3290
 lib/${PKGNAME}/package.conf.d/dph-seq-0.4.0-1f5167ea371010387123b68e975177b2.conf
 lib/${PKGNAME}/package.conf.d/extensible-exceptions-0.1.1.1-95db30aec4429ef77db437055a224b2f.conf
 lib/${PKGNAME}/package.conf.d/filepath-1.1.0.3-07812de93a673f50011d47451bcaac87.conf
 lib/${PKGNAME}/package.conf.d/dph-seq-0.4.0-1f5167ea371010387123b68e975177b2.conf
 lib/${PKGNAME}/package.conf.d/extensible-exceptions-0.1.1.1-95db30aec4429ef77db437055a224b2f.conf
 lib/${PKGNAME}/package.conf.d/filepath-1.1.0.3-07812de93a673f50011d47451bcaac87.conf
-lib/${PKGNAME}/package.conf.d/${PKGNAME}-313a035c30244283e8bfc065a24caaa7.conf
+lib/${PKGNAME}/package.conf.d/${PKGNAME}-7f27c2e5d6d9f4ddfe41304b42636130.conf
 lib/${PKGNAME}/package.conf.d/ghc-binary-0.5.0.2-0782c18dd49d503858ddb60779c7c3d6.conf
 lib/${PKGNAME}/package.conf.d/ghc-prim-0.2.0.0-3fbcc20c802efcd7c82089ec77d92990.conf
 lib/${PKGNAME}/package.conf.d/haskell98-1.0.1.1-0fdaf3b26bc38c43ce8371edf538dbf6.conf
 lib/${PKGNAME}/package.conf.d/ghc-binary-0.5.0.2-0782c18dd49d503858ddb60779c7c3d6.conf
 lib/${PKGNAME}/package.conf.d/ghc-prim-0.2.0.0-3fbcc20c802efcd7c82089ec77d92990.conf
 lib/${PKGNAME}/package.conf.d/haskell98-1.0.1.1-0fdaf3b26bc38c43ce8371edf538dbf6.conf
@@ -2197,6 +2197,7 @@ lib/${PKGNAME}/utf8-string-0.3.4/System/IO/UTF8.hi
 lib/${PKGNAME}/utf8-string-0.3.4/System/IO/UTF8.p_hi
 lib/${PKGNAME}/utf8-string-0.3.4/libHSutf8-string-0.3.4.a
 lib/${PKGNAME}/utf8-string-0.3.4/libHSutf8-string-0.3.4_p.a
 lib/${PKGNAME}/utf8-string-0.3.4/System/IO/UTF8.p_hi
 lib/${PKGNAME}/utf8-string-0.3.4/libHSutf8-string-0.3.4.a
 lib/${PKGNAME}/utf8-string-0.3.4/libHSutf8-string-0.3.4_p.a
+man/man1/ghc.1
 share/doc/ghc/html/Cabal/authors.html
 share/doc/ghc/html/Cabal/bugs.html
 share/doc/ghc/html/Cabal/builders.html
 share/doc/ghc/html/Cabal/authors.html
 share/doc/ghc/html/Cabal/bugs.html
 share/doc/ghc/html/Cabal/builders.html
@@ -4444,4 +4445,3 @@ share/doc/ghc/html/users_guide/win32-dlls.html
 share/doc/ghc/html/users_guide/win32.html
 share/doc/ghc/html/users_guide/wrong-compilee.html
 share/doc/ghc/html/users_guide/wrong.html
 share/doc/ghc/html/users_guide/win32.html
 share/doc/ghc/html/users_guide/wrong-compilee.html
 share/doc/ghc/html/users_guide/wrong.html
-man/man1/ghc.1