]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
DEINSTALL script to remove package.cache
authorPHO <pho@cielonegro.org>
Thu, 30 Dec 2010 06:26:15 +0000 (15:26 +0900)
committerPHO <pho@cielonegro.org>
Thu, 30 Dec 2010 06:26:15 +0000 (15:26 +0900)
DEINSTALL [new file with mode: 0644]
Makefile

diff --git a/DEINSTALL b/DEINSTALL
new file mode 100644 (file)
index 0000000..14c866d
--- /dev/null
+++ b/DEINSTALL
@@ -0,0 +1,9 @@
+#!/bin/sh
+#
+DISTNAME="@DISTNAME@"
+
+case ${STAGE} in
+    DEINSTALL)
+        ${RM} -f ${PKG_PREFIX}/lib/${DISTNAME}/package.conf.d/package.cache
+        ;;
+esac
index 492c75576e76fec883f2f50769a41bd604b80d9a..55d052d3adf91d5a16ab2aa8423cf8c4c42d5134 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -178,6 +178,9 @@ do-configure:
 #      ${RUN} ${ECHO} "GhcRtsCcOpts = -O0 -g" >> ${WRKSRC}/mk/build.mk
 #.endif
 
+# Substitutions for INSTALL and DEINSTALL.
+FILES_SUBST+=  DISTNAME=${DISTNAME}
+
 # Some unused scripts don't pass the portability test.
 CHECK_PORTABILITY_SKIP+=       distrib/prep-bin-dist-mingw