]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/commitdiff
Update the building guide for ghc-7.4.1
authorPHO <pho@cielonegro.org>
Mon, 6 Feb 2012 23:01:28 +0000 (08:01 +0900)
committerPHO <pho@cielonegro.org>
Mon, 6 Feb 2012 23:01:28 +0000 (08:01 +0900)
Makefile
TODO

index a50424af8c6bdf2f74c192c62f2475bc43e99f41..3e50ccd2c09bef1160749b3b946869ac1ba9ccdd 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -131,7 +131,10 @@ ${WRKDIR}/stamp-rewrite-hc-paths: ${WRKDIR}/stamp-extract-hc
                                   -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
                        ${MV} -f $$i.tmp $$i; \
                done && \
                                   -e "s#\\[\\[GHC_SOURCE_PATH\\]\\]#`${PWD_CMD}`#g" $$i > $$i.tmp; \
                        ${MV} -f $$i.tmp $$i; \
                done && \
-               ${TOUCH} -r inplace/lib/package.conf.d */*/package-data.mk */*/*/package-data.mk && \
+               ${TOUCH} -r inplace/lib/package.conf.d \
+                                       */*/package-data.mk \
+                                       */*/*/package-data.mk \
+                                       compiler/stage?/build/Config.hs && \
                ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
                ${TOUCH} ${.TARGET}
 
 ${WRKDIR}/stamp-bootstrap-ghc: ${WRKDIR}/stamp-rewrite-hc-paths
diff --git a/TODO b/TODO
index cc117ccb6b3d5895b7d8824107131a95872c0acf..d4c5fdbd6c71d3f3838ea3f71d06cfa7791f8cd4 100644 (file)
--- a/TODO
+++ b/TODO
@@ -25,7 +25,6 @@ Extract the source archive and duplicate the source tree, one for
 Build some configuration files::
 
     $ cd ghc-{VERSION}-target
 Build some configuration files::
 
     $ cd ghc-{VERSION}-target
-    $ ln -s /bin/pwd utils/ghc-pwd/ghc-pwd
     $ ./configure --enable-hc-boot
     $ echo "INTEGER_LIBRARY = integer-simple" > mk/build.mk
     $ gmake bootstrapping-files
     $ ./configure --enable-hc-boot
     $ echo "INTEGER_LIBRARY = integer-simple" > mk/build.mk
     $ gmake bootstrapping-files
@@ -63,7 +62,8 @@ contents::
 
 Copy some configuration files from the ``-target`` tree::
 
 
 Copy some configuration files from the ``-target`` tree::
 
-    $ cp ../ghc-{VERSION}-target/includes/{ghcautoconf.h,DerivedConstants.h,GHCConstants.h} includes/
+    $ cp -r ../ghc-{VERSION}-target/includes/dist-{ghcconstants,derivedconstants} includes/
+    $ cp ../ghc-{VERSION}-target/includes/ghcautoconf.h includes/
 
 Build it::
 
 
 Build it::