]> gitweb @ CieloNegro.org - pkgsrc-xorg-server.git/blobdiff - Makefile
At least it compiles now. Hope it works too...
[pkgsrc-xorg-server.git] / Makefile
index 4eb755d60733a0751e823c8eb5da24ed59b30ffe..e9d4d15f03b217ad14fc76b4c455ad3b0e8e0cd5 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,41 +1,25 @@
 # $NetBSD$
 
-DISTNAME=      xorg-server-1.4.2
+DISTNAME=      xorg-server-1.4.2-apple35
 PKGNAME=       modular-${DISTNAME}
-PKGREVISION=   4
 CATEGORIES=    x11
 
-MASTER_SITES=  ${MASTER_SITE_XORG:=xserver/}
+MASTER_SITES=  http://static.macosforge.org/xquartz/downloads/src/
 EXTRACT_SUFX=  .tar.bz2
 
-.include "../../mk/bsd.prefs.mk"
-
-.if ${OPSYS} == "Darwin"
-DISTFILES+=            xserver-1.4.2-pkgsrc.patch
-.else
-PATCHFILES+=   xserver-1.4.2-pkgsrc.patch
-PATCH_DIST_STRIP=      -p1
-.endif
-SITES.xserver-1.4.2-pkgsrc.patch=\
-                       ftp://ftp.NetBSD.org/pub/NetBSD/misc/bjs/patchfiles/
-
-DISTFILES+=            xorg-server-1.4.2-apple35.tar.bz2
-SITES.xorg-server-1.4.2-apple35.tar.bz2=\
-       http://static.macosforge.org/xquartz/downloads/src/
-
-SPECIAL_PERMS+=                bin/Xorg ${SETUID_ROOT_PERMS}
+ONLY_FOR_PLATFORM= Darwin-*-*
 
 PKG_DESTDIR_SUPPORT=   user-destdir
 
-MAINTAINER=            bjs@NetBSD.org
-COMMENT=               Xorg X11 Server from modular X.org X11
+MAINTAINER=            pho@cielonegro.org
+COMMENT=               Xorg X11 Server from modular X.org X11 for MacOS X
 
 DEPENDS+=              xkbcomp-[0-9]*:../../x11/xkbcomp
 
 USE_LIBTOOL=           yes
 GNU_CONFIGURE=         yes
 PKGCONFIG_OVERRIDE+=   xorg-server.pc.in
-USE_TOOLS+=            gmake pkg-config
+USE_TOOLS+=            gmake pkg-config perl
 
 BUILD_DEFS+=           VARBASE
 BUILD_DEFS_EFFECTS+=   XKB_OUTPUT_DIR
@@ -43,48 +27,16 @@ BUILD_DEFS_EFFECTS+=        XKB_OUTPUT_DIR
 OWN_DIRS+=             ${XKB_OUTPUT_DIR}
 XKB_OUTPUT_DIR?=       ${VARBASE}/db/xkb
 
+DARWIN_X11_APP_DIR?= ${PREFIX}/libexec/modular-xorg-server/
+
 CONFIGURE_ARGS+=       --localstatedir=${VARBASE:Q}
 CONFIGURE_ARGS+=       --with-xkb-output=${XKB_OUTPUT_DIR:Q}
-
-.if ${OPSYS} == "Darwin"
-EXTRACT_ONLY=  xorg-server-1.4.2-apple35.tar.bz2
-WRKSRC=                        ${WRKDIR}/xorg-server-1.4.2-apple35
-.else
-EXTRACT_ONLY=  xorg-server-1.4.2.tar.bz2
-WRKSRC=                        ${WRKDIR}/xorg-server-1.4.2
-.endif
-
-CONFIGURE_ARGS+=       --with-release-version=${PKGNAME}
-CONFIGURE_ARGS+=       --with-vendor-name="The NetBSD Foundation"
-CONFIGURE_ARGS+=       --with-vendor-name-short="pkgsrc"
-.if ${OPSYS} == "NetBSD"
-CONFIGURE_ARGS+=       --with-builder-addr="tech-x11@NetBSD.org"
-CONFIGURE_ARGS+=       --with-os-vendor="The NetBSD Foundation"
-.endif
-CONFIGURE_ARGS+=       --with-os-name=${MACHINE_PLATFORM}
-CONFIGURE_ARGS+=       --with-vendor-web="http://www.pkgsrc.org/"
-
-.if ${OPSYS} != "Darwin"
-CONFIGURE_ARGS+=       --enable-xorg
-.endif
-CONFIGURE_ARGS+=       --disable-config-hal
-CONFIGURE_ARGS+=       --disable-dmx
-CONFIGURE_ARGS+=       --disable-xprint
-CONFIGURE_ARGS+=       --disable-xwin
-CONFIGURE_ARGS+=       --disable-xephyr
-CONFIGURE_ARGS+=       --disable-kdrive
-CONFIGURE_ARGS+=       --disable-kdrive-vesa
-CONFIGURE_ARGS+=       --disable-xfake
-CONFIGURE_ARGS+=       --disable-xsdl
-CONFIGURE_ARGS+=       --disable-xfbdev
-CONFIGURE_ARGS+=       --disable-kbd_mode      # deprecated
-CONFIGURE_ARGS+=       --enable-builtin-fonts
-CONFIGURE_ARGS+=       --enable-dri
-
-CONFIGURE_ARGS+=       --with-int10=x86emu
+CONFIGURE_ARGS+=       --with-apple-applications-dir=${DARWIN_X11_APP_DIR:Q}
 
 CONFIGURE_ENV+=                APP_MAN_SUFFIX=1 FILE_MAN_SUFFIX=5
 
+FILES_SUBST+=          DARWIN_X11_APP_DIR=${DARWIN_X11_APP_DIR}
+
 DEPENDS+=              xkeyboard-config-[0-9]*:../../x11/xkeyboard-config
 
 BUILDLINK_API_DEPENDS.compositeproto+= compositeproto>=0.4
@@ -103,13 +55,9 @@ BUILDLINK_API_DEPENDS.xf86dgaproto+=        xf86dgaproto>=2.0.3
 .endif
 BUILDLINK_API_DEPENDS.inputproto+=     inputproto>=1.4.2
 
-post-extract: dri-post-extract
-       ${CP} ${FILESDIR}/modeline2c.awk ${WRKSRC}/hw/xfree86/common
-#      ${CP} ${FILESDIR}/Xplugin.h ${WRKSRC}/miext/rootless/
-       ${CP} ${FILESDIR}/Xplugin.h ${WRKSRC}/hw/xquartz/xpr/
-#      ${RM} -f ${WRKDIR}/Mesa-7.0.2/src/mesa/Makefile.orig
-#      ${RM} -f ${WRKDIR}/Mesa-7.0.2/docs/README.MINGW32.orig
-#      ${CP} ${FILESDIR}/prim_x86_gcc.h ${WRKSRC}/hw/xfree86/x86emu/x86emu/
+# Workaround for missing Xplugin.h
+pre-configure:
+       ${CP} ${FILESDIR}/Xplugin.h ${BUILDLINK_DIR}/include
 
 .include "options.mk"
 
@@ -133,7 +81,6 @@ post-extract: dri-post-extract
 .include "../../x11/libXt/buildlink3.mk"
 .include "../../x11/libXxf86misc/buildlink3.mk"
 .include "../../x11/libXxf86vm/buildlink3.mk"
-.include "../../x11/libdrm/buildlink3.mk"
 .include "../../x11/libxkbfile/buildlink3.mk"
 .include "../../x11/libxkbui/buildlink3.mk"
 .include "../../x11/pixman/buildlink3.mk"
@@ -148,16 +95,12 @@ post-extract: dri-post-extract
 .include "../../x11/xextproto/buildlink3.mk"
 .include "../../x11/xf86bigfontproto/buildlink3.mk"
 .include "../../x11/xf86dgaproto/buildlink3.mk"
-.include "../../x11/xf86driproto/buildlink3.mk"
 .include "../../x11/xf86miscproto/buildlink3.mk"
 .include "../../x11/xf86vidmodeproto/buildlink3.mk"
 .include "../../x11/xineramaproto/buildlink3.mk"
 .include "../../x11/xproto/buildlink3.mk"
 .include "../../x11/xtrans/buildlink3.mk"
-
-.if ${OPSYS} == "Darwin"
 .include "../../wip/libAppleWM/buildlink3.mk"
 .include "../../wip/applewmproto/buildlink3.mk"
-.endif
 
 .include "../../mk/bsd.pkg.mk"