]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - patches/patch-rts_ghc.mk
GHC 7.0.3 for powerpc-apple-darwin. It looks fully working, including GHCi!
[pkgsrc-ghc.git] / patches / patch-rts_ghc.mk
diff --git a/patches/patch-rts_ghc.mk b/patches/patch-rts_ghc.mk
new file mode 100644 (file)
index 0000000..bb7d3b2
--- /dev/null
@@ -0,0 +1,38 @@
+$NetBSD$
+
+The first section:
+  HC bootstrapping has bitrotted further. We need to build RtsProbes.h
+  before compiling Capability.hc but rts/ghc.mk doesn't have such
+  rule.
+
+The second section:
+  This is pkgsrc specific. /usr/sbin/dtrace gets confused when we have
+  ghc wrappers in the PATH so we have to hide them.
+
+
+--- rts/ghc.mk.orig    2011-03-26 18:10:07.000000000 +0000
++++ rts/ghc.mk
+@@ -452,12 +452,14 @@ rts_dist_MKDEPENDC_OPTS += -DPROFILING -
+ ifeq "$(USE_DTRACE)" "YES"
+ rts_dist_MKDEPENDC_OPTS += -Irts/dist/build
++rts_CC_OPTS += -Irts/dist/build
+ endif
+ $(eval $(call build-dependencies,rts,dist,1))
+ $(rts_dist_depfile_c_asm) : libffi/dist-install/build/ffi.h $(DTRACEPROBES_H)
++rts/dist/build/Capability.o : $(DTRACEPROBES_H)
+ #-----------------------------------------------------------------------------
+ # libffi stuff
+@@ -489,7 +491,7 @@ endif
+ DTRACEPROBES_SRC = rts/RtsProbes.d
+ $(DTRACEPROBES_H): $(DTRACEPROBES_SRC) includes/ghcplatform.h | $$(dir $$@)/.
+-      "$(DTRACE)" $(filter -I%,$(rts_CC_OPTS)) -C $(DTRACE_FLAGS) -h -o $@ -s $<
++      env PATH=/usr/bin "$(DTRACE)" $(filter -I%,$(rts_CC_OPTS)) -C $(DTRACE_FLAGS) -h -o $@ -s $<
+ endif
+ # -----------------------------------------------------------------------------