.include "../../audio/liba52/buildlink3.mk"
.include "../../audio/libsndfile/buildlink3.mk"
.include "../../audio/libvorbis/buildlink3.mk"
+.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../wip/libuuid/buildlink3.mk" # should be in "devel" category
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/jpeg/buildlink3.mk"
$NetBSD$
-SHA1 (patch-alsa_m4) = 6a15005a08efa0ae96a44b2e9118a121f31f3fa5
+SHA1 (patch-alsa_m4) = 8622849fd0539f961be8c42bb95f5df5284e8c61
SHA1 (patch-audiooss_C) = cd38e2cffdb3477732f929b41bf207d687ee008b
-SHA1 (patch-configure_in) = d6166055b7f6f4c083a4b480fc16244b323513e9
+SHA1 (patch-cdripper_h) = 8a2f3f1595297bc71506d534ec555b37c8bec6af
+SHA1 (patch-cinelerra_Makefile_am) = a1ff38ffdac1e874a32904bdc8fb1e7e5a0a904f
+SHA1 (patch-configure_in) = bc6cc0ecefb32ae03f4b82d89a94db54bb40a506
SHA1 (patch-ffmpeg_C) = ff62028269104f5ebc9973872cdaaf407aa64dde
SHA1 (patch-filesystem_C) = 98591b4ea29f303469552763193cd049105e2644
-SHA1 (patch-mpeg3ifo_c) = d0b9b7fbc16eeaa92f69d157c58485e6746f0eb9
-SHA1 (patch-mpeg3io_c) = 49a8714c37b201581e7bc89eb073fdd3346a2b01
-SHA1 (patch-mpeg3tocutil_c) = 8f5942d7cd8fbcb98748b0d8b04aa1c324f512f3
+SHA1 (patch-ieee1394_ioctl_h) = 0939e6b1fa2cfbdd035c4100babb2804697636f1
+SHA1 (patch-mpeg3ifo_c) = 4d484a48f319f23d4ee2d27edd54405006ea2512
+SHA1 (patch-mpeg3io_c) = 8dc3b7d475413a516c8834a0e3bf2cb45f8d7a74
+SHA1 (patch-mpeg3tocutil_c) = 7a250f7fc05d97fb882e3b1dd6b6c0a690eb3abc
SHA1 (patch-qtffmpeg_c) = a4cd7fee7fc5d11f0ddb3bc728795ac0e3bc2734
SHA1 (patch-qtprivate_h) = 2c48c0719e4d5cad1ba8f9cfe03a9892ca49fe11
SHA1 (patch-quantize_c) = 0c3062bf9357850e1d02a2456dff6c60254029f2
+SHA1 (patch-renderfarm_C) = 88e7fe3fb6d7ac8c294f26e067c8ad4fc4f06bbb
+SHA1 (patch-renderfarmclient_C) = 3564f488fd1190a550d490813bbafe9208fbbfaf
SHA1 (patch-thread_C) = c11ffe8f2a0d7122dd2492fe4e40258212a3f62b
-SHA1 (patch-util_c) = 82c9512cc995c62b9300dce02261517d5b296879
+SHA1 (patch-util_c) = e979f22de2ffc5ff2275ea0865e77f342042808f
+SHA1 (patch-vdevicebuz_C) = 0e54e56a89b5d7edbf7aa791dcbc9931718952ee
+SHA1 (patch-vdevicev4l_C) = 01d4187ff2f873fac5b7c8eb25791c7ea67a9167
+SHA1 (patch-vdevicev4l_h) = a72fdf4255c69b5adaf64a46e5a44b6ef46f5520
$NetBSD$
---- m4/alsa.m4.orig 2010-01-29 02:30:00.000000000 +0000
+--- m4/alsa.m4.orig 2010-01-29 06:11:05.000000000 +0000
+++ m4/alsa.m4
@@ -52,7 +52,7 @@ if test "$alsa_prefix" != "" ; then
fi
--- /dev/null
+$NetBSD$
+
+--- plugins/cdripper/cdripper.h.orig 2010-01-29 08:54:10.000000000 +0000
++++ plugins/cdripper/cdripper.h
+@@ -24,8 +24,6 @@
+
+ #include "pluginaclient.h"
+
+-#include <linux/cdrom.h>
+-
+ #define NFRAMES 2
+ #define FRAMESIZE 2352
+
--- /dev/null
+$NetBSD$
+
+--- cinelerra/Makefile.am.orig 2010-01-29 08:45:33.000000000 +0000
++++ cinelerra/Makefile.am
+@@ -689,6 +689,7 @@ cinelerra_LDADD = \
+ $(FIREWIRE_LDFLAGS) \
+ $(LIBDV_LIBS) \
+ -luuid \
++ @LTLIBINTL@ \
+ $(MJPEG_LIBS)
+
+ EXTRA_DIST = gen-feather-h
$NetBSD$
---- configure.in.orig 2010-01-29 05:05:28.000000000 +0000
+--- configure.in.orig 2010-01-29 06:11:05.000000000 +0000
+++ configure.in
@@ -19,6 +19,9 @@ AC_ENABLE_SHARED
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
+AC_CHECK_TYPE([__off64_t], [int64_t])
-+AC_CHECK_HEADERS([mntent.h fstab.h])
++AC_CHECK_HEADERS([mntent.h fstab.h linux/videodev.h linux/cdrom.h])
+
# hack for libtool 1.5 -- this is ugly and probably wrong, but works
LTC_FLAGS="--tag=CC"
--- /dev/null
+$NetBSD$
+
+--- cinelerra/ieee1394-ioctl.h.orig 2010-01-29 07:26:58.000000000 +0000
++++ cinelerra/ieee1394-ioctl.h
+@@ -25,9 +25,6 @@
+ #ifndef __IEEE1394_IOCTL_H
+ #define __IEEE1394_IOCTL_H
+
+-#include <linux/ioctl.h>
+-#include <linux/types.h>
+-
+
+ /* AMDTP Gets 6 */
+ #define AMDTP_IOC_CHANNEL _IOW('#', 0x00, struct amdtp_ioctl)
$NetBSD$
---- libmpeg3/mpeg3ifo.c.orig 2010-01-29 04:58:31.000000000 +0000
+--- libmpeg3/mpeg3ifo.c.orig 2010-01-29 06:11:05.000000000 +0000
+++ libmpeg3/mpeg3ifo.c
@@ -1,4 +1,3 @@
-#include <byteswap.h>
$NetBSD$
---- libmpeg3/mpeg3io.c.orig 2010-01-29 05:26:39.000000000 +0000
+--- libmpeg3/mpeg3io.c.orig 2010-01-29 06:11:05.000000000 +0000
+++ libmpeg3/mpeg3io.c
@@ -1,7 +1,7 @@
#include "mpeg3private.h"
$NetBSD$
---- libmpeg3/mpeg3tocutil.c.orig 2010-01-29 05:32:17.000000000 +0000
+--- libmpeg3/mpeg3tocutil.c.orig 2010-01-29 06:11:05.000000000 +0000
+++ libmpeg3/mpeg3tocutil.c
@@ -1415,8 +1415,8 @@ int64_t mpeg3_get_source_date(mpeg3_t *f
--- /dev/null
+$NetBSD$
+
+--- cinelerra/renderfarm.C.orig 2010-01-29 07:39:35.000000000 +0000
++++ cinelerra/renderfarm.C
+@@ -51,6 +51,9 @@
+ #include <sys/un.h>
+ #include <unistd.h>
+
++#if !defined(AF_FILE)
++# define AF_FILE AF_UNIX
++#endif
+
+
+
--- /dev/null
+$NetBSD$
+
+--- cinelerra/renderfarmclient.C.orig 2010-01-29 07:40:39.000000000 +0000
++++ cinelerra/renderfarmclient.C
+@@ -50,6 +50,9 @@
+ #include <sys/wait.h>
+ #include <unistd.h>
+
++#if !defined(AF_FILE)
++# define AF_FILE AF_UNIX
++#endif
+
+
+
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
+@@ -15,9 +14,9 @@
+
+ int64_t quicktime_get_file_length(char *path)
+ {
+- struct stat64 status;
+- if(stat64(path, &status))
+- perror("quicktime_get_file_length stat64:");
++ struct stat status;
++ if(stat(path, &status))
++ perror("quicktime_get_file_length stat:");
+ return status.st_size;
+ }
+
--- /dev/null
+$NetBSD$
+
+--- cinelerra/vdevicebuz.C.orig 2010-01-29 07:46:20.000000000 +0000
++++ cinelerra/vdevicebuz.C
+@@ -24,6 +24,8 @@
+ #undef _LARGEFILE64_SOURCE
+ #undef _FILE_OFFSET_BITS
+
++#include "config.h"
++
+ #include "assets.h"
+ #include "bcsignals.h"
+ #include "channel.h"
+@@ -43,9 +45,11 @@
+
+ #include <errno.h>
+ #include <stdint.h>
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ #include <linux/kernel.h>
+ //#include <linux/videodev2.h>
+ #include <linux/videodev.h>
++#endif
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
+ #include <sys/mman.h>
+@@ -107,6 +111,7 @@ void VDeviceBUZInput::start()
+ Thread::start();
+ }
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ void VDeviceBUZInput::run()
+ {
+ struct buz_sync bsync;
+@@ -117,7 +122,7 @@ void VDeviceBUZInput::run()
+ Thread::enable_cancel();
+ if(ioctl(device->jvideo_fd, BUZIOC_SYNC, &bsync) < 0)
+ {
+- perror("VDeviceBUZInput::run BUZIOC_SYNC");
++ fprintf(stderr, "VDeviceBUZInput::run BUZIOC_SYNC\n");
+ if(done) return;
+ Thread::disable_cancel();
+ }
+@@ -152,6 +157,11 @@ void VDeviceBUZInput::run()
+ }
+ }
+ }
++#else
++void VDeviceBUZInput::run() {
++ fprintf(stderr, "VDeviceBUZInput::run (Warning: unavailable for this platform)\n");
++}
++#endif
+
+ void VDeviceBUZInput::get_buffer(char **ptr, int *size)
+ {
+@@ -444,6 +454,7 @@ int VDeviceBUZ::set_picture(PictureConfi
+ return 0;
+ }
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceBUZ::get_norm(int norm)
+ {
+ switch(norm)
+@@ -453,6 +464,11 @@ int VDeviceBUZ::get_norm(int norm)
+ case SECAM: return VIDEO_MODE_SECAM; break;
+ }
+ }
++#else
++int VDeviceBUZ::get_norm(int norm) {
++ return -1;
++}
++#endif
+
+ int VDeviceBUZ::read_buffer(VFrame *frame)
+ {
+@@ -500,6 +516,7 @@ int VDeviceBUZ::read_buffer(VFrame *fram
+ return 0;
+ }
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceBUZ::open_input_core(Channel *channel)
+ {
+ jvideo_fd = open(device->in_config->buz_in_device, O_RDONLY);
+@@ -621,7 +638,15 @@ int VDeviceBUZ::open_input_core(Channel
+ //printf("VDeviceBUZ::open_input_core 2\n");
+ return 0;
+ }
++#else
++int VDeviceBUZ::open_input_core(Channel *channel) {
++ fprintf(stderr, "VDeviceBUZ::open_input (Warning: unavailable feature on this platform)\n");
++ jvideo_fd = 0;
++ return 1;
++}
++#endif
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceBUZ::open_output_core(Channel *channel)
+ {
+ //printf("VDeviceBUZ::open_output 1\n");
+@@ -677,9 +702,15 @@ int VDeviceBUZ::open_output_core(Channel
+ //printf("VDeviceBUZ::open_output 2\n");
+ return 0;
+ }
++#else
++int VDeviceBUZ::open_output_core(Channel *channel) {
++ fprintf(stderr, "VDeviceBUZ::open_output (Warning: unavailable feature on this platform)\n");
++ jvideo_fd = 0;
++ return 1;
++}
++#endif
+
+-
+-
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceBUZ::write_buffer(VFrame *frame, EDL *edl)
+ {
+ //printf("VDeviceBUZ::write_buffer 1\n");
+@@ -753,6 +784,12 @@ int VDeviceBUZ::write_buffer(VFrame *fra
+
+ return 0;
+ }
++#else
++int VDeviceBUZ::write_buffer(VFrame *frame, EDL *edl) {
++ fprintf(stderr, "VDeviceBUZ::write_buffer (Warning: unavailable feature on this platform)\n");
++ return 0;
++}
++#endif
+
+ void VDeviceBUZ::new_output_buffer(VFrame *output,
+ int colormodel)
--- /dev/null
+$NetBSD$
+
+--- cinelerra/vdevicev4l.C.orig 2010-01-29 08:22:11.000000000 +0000
++++ cinelerra/vdevicev4l.C
+@@ -25,6 +25,7 @@
+ #undef _LARGEFILE_SOURCE
+ #undef _LARGEFILE64_SOURCE
+
++#include "config.h"
+
+ #include "assets.h"
+ #include "bcsignals.h"
+@@ -108,6 +109,7 @@ int VDeviceV4L::close_v4l()
+
+ int VDeviceV4L::unmap_v4l_shmem()
+ {
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ if(capture_buffer)
+ {
+ if(shared_memory)
+@@ -116,9 +118,11 @@ int VDeviceV4L::unmap_v4l_shmem()
+ delete capture_buffer;
+ capture_buffer = 0;
+ }
++#endif
+ return 0;
+ }
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceV4L::v4l_init()
+ {
+ int i;
+@@ -179,11 +183,20 @@ int VDeviceV4L::v4l_init()
+ got_first_frame = 0;
+ return 0;
+ }
++#else
++int VDeviceV4L::v4l_init() {
++ fprintf(stderr, "VDeviceV4L::v4l_init (Warning: unavailble feature on this platform)\n");
++ input_fd = 0;
++ return 0;
++}
++#endif
+
+ void VDeviceV4L::v4l1_start_capture()
+ {
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ for(int i = 0; i < MIN(capture_params.frames, device->in_config->capture_length); i++)
+ capture_frame(i);
++#endif
+ }
+
+
+@@ -195,6 +208,7 @@ void VDeviceV4L::v4l1_start_capture()
+
+ int VDeviceV4L::v4l1_get_inputs()
+ {
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ struct video_channel channel_struct;
+ int i = 0, done = 0;
+ char *new_source;
+@@ -215,6 +229,7 @@ int VDeviceV4L::v4l1_get_inputs()
+ }
+ i++;
+ }
++#endif
+ return 0;
+ }
+
+@@ -227,6 +242,7 @@ int VDeviceV4L::set_mute(int muted)
+
+ int VDeviceV4L::v4l1_set_mute(int muted)
+ {
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ struct video_audio audio;
+
+ if(ioctl(input_fd, VIDIOCGAUDIO, &audio))
+@@ -244,6 +260,7 @@ int VDeviceV4L::v4l1_set_mute(int muted)
+ if(ioctl(input_fd, VIDIOCSAUDIO, &audio) < 0)
+ perror("VDeviceV4L::ioctl VIDIOCSAUDIO");
+ return 0;
++#endif
+ }
+
+
+@@ -288,6 +305,7 @@ int VDeviceV4L::get_best_colormodel(Asse
+ return result;
+ }
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ unsigned long VDeviceV4L::translate_colormodel(int colormodel)
+ {
+ unsigned long result = 0;
+@@ -303,12 +321,18 @@ unsigned long VDeviceV4L::translate_colo
+ //printf("VDeviceV4L::translate_colormodel %d\n", result);
+ return result;
+ }
++#else
++unsigned long VDeviceV4L::translate_colormodel(int) {
++ return 0;
++}
++#endif
+
+ int VDeviceV4L::set_channel(Channel *channel)
+ {
+ return v4l1_set_channel(channel);
+ }
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceV4L::v4l1_set_channel(Channel *channel)
+ {
+ struct video_channel channel_struct;
+@@ -352,7 +376,13 @@ int VDeviceV4L::v4l1_set_channel(Channel
+ // set_mute(0);
+ return 0;
+ }
++#else
++int VDeviceV4L::v4l1_set_channel(Channel*) {
++ return 0;
++}
++#endif
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceV4L::v4l1_get_norm(int norm)
+ {
+ switch(norm)
+@@ -363,13 +393,18 @@ int VDeviceV4L::v4l1_get_norm(int norm)
+ }
+ return 0;
+ }
++#else
++int VDeviceV4L::v4l1_get_norm(int) {
++ return 0;
++}
++#endif
+
+ int VDeviceV4L::set_picture(PictureConfig *picture)
+ {
+ v4l1_set_picture(picture);
+ }
+
+-
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceV4L::v4l1_set_picture(PictureConfig *picture)
+ {
+ int brightness = (int)((float)picture->brightness / 100 * 32767 + 32768);
+@@ -394,8 +429,13 @@ int VDeviceV4L::v4l1_set_picture(Picture
+ perror("VDeviceV4L::v4l1_set_picture VIDIOCGPICT");
+ return 0;
+ }
++#else
++int VDeviceV4L::v4l1_set_picture(PictureConfig*) {
++ return 0;
++}
++#endif
+
+-
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceV4L::capture_frame(int capture_frame_number)
+ {
+ struct video_mmap params;
+@@ -409,7 +449,13 @@ int VDeviceV4L::capture_frame(int captur
+ perror("VDeviceV4L::capture_frame VIDIOCMCAPTURE");
+ return 0;
+ }
++#else
++int VDeviceV4L::capture_frame(int) {
++ return 0;
++}
++#endif
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceV4L::wait_v4l_frame()
+ {
+ //printf("VDeviceV4L::wait_v4l_frame 1 %d\n", capture_frame_number);
+@@ -418,17 +464,29 @@ int VDeviceV4L::wait_v4l_frame()
+ //printf("VDeviceV4L::wait_v4l_frame 2 %d\n", capture_frame_number);
+ return 0;
+ }
++#else
++int VDeviceV4L::wait_v4l_frame() {
++ return 0;
++}
++#endif
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceV4L::read_v4l_frame(VFrame *frame)
+ {
+ frame_to_vframe(frame, (unsigned char*)capture_buffer + capture_params.offsets[capture_frame_number]);
+ return 0;
+ }
++#else
++int VDeviceV4L::read_v4l_frame(VFrame *) {
++ return 0;
++}
++#endif
+
+ #ifndef MIN
+ #define MIN(x, y) ((x) < (y) ? (x) : (y))
+ #endif
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceV4L::frame_to_vframe(VFrame *frame, unsigned char *input)
+ {
+ int inwidth, inheight;
+@@ -525,9 +583,13 @@ int VDeviceV4L::frame_to_vframe(VFrame *
+ }
+ return 0;
+ }
++#else
++int VDeviceV4L::frame_to_vframe(VFrame *, unsigned char *) {
++ return 0;
++}
++#endif
+
+-
+-
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceV4L::next_frame(int previous_frame)
+ {
+ int result = previous_frame + 1;
+@@ -535,7 +597,13 @@ int VDeviceV4L::next_frame(int previous_
+ if(result >= MIN(capture_params.frames, device->in_config->capture_length)) result = 0;
+ return result;
+ }
++#else
++int VDeviceV4L::next_frame(int) {
++ return 0;
++}
++#endif
+
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ int VDeviceV4L::read_buffer(VFrame *frame)
+ {
+ int result = 0;
+@@ -561,7 +629,11 @@ SET_TRACE
+
+ return 0;
+ }
+-
++#else
++int VDeviceV4L::read_buffer(VFrame *) {
++ return 0;
++}
++#endif
+
+
+
--- /dev/null
+$NetBSD$
+
+--- cinelerra/vdevicev4l.h.orig 2010-01-29 08:20:15.000000000 +0000
++++ cinelerra/vdevicev4l.h
+@@ -23,7 +23,9 @@
+ #define VDEVICEV4L_H
+
+ #include "vdevicebase.h"
+-#include <linux/videodev.h>
++#if defined(HAVE_LINUX_VIDEODEV_H)
++# include <linux/videodev.h>
++#endif
+ #include "videodevice.inc"
+
+ class VDeviceV4L : public VDeviceBase
+@@ -66,10 +68,12 @@ private:
+ int colormodel;
+
+ // Video4Linux
++#if defined(HAVE_LINUX_VIDEODEV_H)
+ struct video_capability cap1;
+ struct video_window window_params;
+ struct video_picture picture_params;
+ struct video_mbuf capture_params; // Capture for Video4Linux
++#endif
+
+ // Common
+ char *capture_buffer; // sequentual capture buffers for v4l1 or read buffer for v4l2