]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
moved some USE_TOOLS from Makefile to stage0.mk, the actual user of those tools.
[pkgsrc-ghc.git] / Makefile
index 8ed0746e3db7c97b62d088856978d5e6aca2d3dd..8ad240a370b1e78ff6b3a54fa5ea9ae749ea6416 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -13,6 +13,7 @@ DISTFILES=    ${DISTNAME}-src.tar.bz2
 DISTFILES+=    ${DISTNAME}-boot-i386-unknown-freebsd8.0.tar.bz2
 DISTFILES+=    ${DISTNAME}-boot-i386-unknown-netbsdelf6.99.1.tar.bz2
 DISTFILES+=    ${DISTNAME}-boot-powerpc-apple-darwin9.8.0.tar.bz2
+DISTFILES+=    ${DISTNAME}-boot-x86_64-unknown-linux-gnu.tar.bz2
 
 .for i in ${DISTFILES:M*-boot-*}
 SITES.${i}=    http://static.cielonegro.org/archive/
@@ -29,7 +30,11 @@ PKG_DESTDIR_SUPPORT= user-destdir
 #
 # If you want to build HC packages yourself, follow instructions in
 # the ./TODO file.
-ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386 Darwin-*-powerpc
+ONLY_FOR_PLATFORM= \
+       Darwin-*-powerpc \
+       FreeBSD-*-i386 \
+       Linux-*-x86_64 \
+       NetBSD-*-i386
 
 # We must provide the real path to gcc to the ./configure script,
 # because GHC has a runtime dependency on it. Aren't there any ways
@@ -45,7 +50,7 @@ CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
 CONFIGURE_ARGS+= --with-gcc=${CCPATH}
 .endif
 
-USE_TOOLS+=    autoconf date gmake gtar perl perl:run
+USE_TOOLS+=    gmake perl:run
 CONFIGURE_ENV+=        PerlCmd=${PERL5:Q}
 
 # We don't want to extract all of the DISTFILEs.
@@ -96,7 +101,7 @@ CHECK_PORTABILITY_SKIP+=     distrib/prep-bin-dist-mingw
 # GHC currently *requires* ${PREFIX}/lib to be in
 # "/etc/ld-elf.so.conf". See
 # http://hackage.haskell.org/trac/ghc/ticket/2933
-CHECK_SHLIBS_SUPPORTED=        no
+CHECK_SHLIBS_SUPPORTED=        no
 
 # I guess pdcurses works well but not tested.
 USE_NCURSES=   yes