]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Fixed Makefile bug
[pkgsrc-ghc.git] / Makefile
index a647d2668760f672707115d1a6f055e38e4a950e..e0e6201fcb5d02b2a17d1c59fb7c5fc7a97ec2fa 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,20 @@ PKG_DESTDIR_SUPPORT= user-destdir
 # Unregisterised HC packages are architecture dependent. We have to
 # create more HC packages to support more architectures.
 ONLY_FOR_PLATFORM= NetBSD-*-i386 FreeBSD-*-i386
+# Note: Darwin-*-powerpc is temporarily disabled for now. It shall
+# come back in the near future. Thanks for your patience.
+
+# We must provide the real pass to gcc to the ./configure script,
+# because GHC has a runtime dependency on it. Aren't there any better
+# way than this?
+.include "../../mk/compiler.mk"
+.if empty(CCPATH)
+WARNINGS+= "This package depends on pkgsrc's undocumented variable CCPATH but it disappeared somehow."
+WARNINGS+= "Using hard-coded /usr/bin/gcc as the C compiler..."
+CONFIGURE_ARGS+= --with-gcc=/usr/bin/gcc
+.else
+CONFIGURE_ARGS+= --with-gcc=${CCPATH}
+.endif
 
 USE_TOOLS+=    gmake bsdtar perl:run
 CONFIGURE_ENV+=                PerlCmd=${PERL5:Q}
@@ -31,6 +45,19 @@ CONFIGURE_ENV+=              PerlCmd=${PERL5:Q}
 # We don't want to extract all of the DISTFILEs.
 EXTRACT_ONLY=  ${DISTNAME}-src.tar.bz2
 
+<<<<<<< Makefile
+PLATFORM= ${LOWER_ARCH}-unknown-${LOWER_OPSYS}
+CONFIGURE_ARGS += \
+       --build=${PLATFORM} \
+       --host=${PLATFORM} \
+       --target=${PLATFORM} \
+       --prefix=${PREFIX} \
+       --mandir=${PREFIX}/${PKGMANDIR} \
+       --with-gmp-includes=${PREFIX}/include \
+       --with-gmp-libraries=${PREFIX}/lib \
+       --with-iconv-includes=${PREFIX}/include \
+       --with-iconv-libraries=${PREFIX}/lib
+=======
 CONFIGURE_ARGS += \
        --prefix=${PREFIX} \
        --mandir=${PREFIX}/${PKGMANDIR} \
@@ -38,6 +65,7 @@ CONFIGURE_ARGS += \
        --with-gmp-libraries=${PREFIX}/lib \
        --with-iconv-includes=${PREFIX}/include \
        --with-iconv-libraries=${PREFIX}/lib
+>>>>>>> 1.14
 
 # Build an unregisterised bootstrap compiler and install it directly
 # into the .buildlink directory. But we can't use "make install"