]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - Makefile
Perform dead-code elimination only on NetBSD/i386 as it makes ld(1) take too much...
[pkgsrc-ghc.git] / Makefile
index 421ee4aed34c48dc58b0fd686664a5ee999de48b..fed43ba4311678b3fd79a210dca4e780a119a228 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -137,7 +137,21 @@ ${WRKDIR}/stamp-extract-hc: ${WRKDIR}/stamp-configure-hc-boot
 ${WRKDIR}/stamp-rewrite-hc-paths: ${WRKDIR}/stamp-extract-hc
        ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
                ${PHASE_MSG} "Rewriting source paths in bootstrapping compiler for ${PKGNAME}" && \
-               ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk && \
+               ${SED} -e "s#\\[\\[PREFIX\\]\\]#${PREFIX}#g" ${BOOTSTRAP_BUILD_MK} > mk/build.mk
+.if ${MACHINE_ARCH} == "i386" && ${OPSYS} == "NetBSD"
+#   Unregisterised stage0 compiler gets too large (.text section being
+# over 64 MiB) without dead-code elimination, exceeding NetBSD/i386's
+# kernel default limitation.
+#   Note that stage1 currently doesn't bloat that much (about 42.6
+# MiB), but when it does we have to append
+# CONF_CC_OPTS_STAGE1="-fdata..." and
+# CONF_GCC_LINKER_OPTS_STAGE1="-Wl,--gc-sections" to CONFIGURE_ENV as
+# well. I guess that's a matter of time :(
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
+               ${ECHO} "EXTRA_CC_OPTS += -fdata-sections -ffunction-sections" >> mk/build.mk && \
+               ${ECHO} "EXTRA_CC_OPTS += -Wl,--gc-sections" >> mk/build.mk
+.endif
+       ${RUN} cd ${WRKDIR}/bootstrap/${DISTNAME} && \
                for c in libraries/*/configure; do \
                        (cd `${DIRNAME} $$c` && ${SETENV} ${CONFIGURE_ENV} ${SH} configure ${CONFIGURE_ARGS}); \
                done && \