]> gitweb @ CieloNegro.org - pkgsrc-ghc.git/blobdiff - stage0.mk
moved some USE_TOOLS from Makefile to stage0.mk, the actual user of those tools.
[pkgsrc-ghc.git] / stage0.mk
index d66415a9777d0c45a0c89021bf65e469507ef224..103ad3046e1715d084bd743a959b6348b7a75d46 100644 (file)
--- a/stage0.mk
+++ b/stage0.mk
@@ -1,5 +1,7 @@
 # $NetBSD$
 
+USE_TOOLS+=    autoconf date gtar perl
+
 # Build an unregisterised bootstrap compiler and install it directly
 # into the .buildlink directory. But we can't use "make install"
 # because we don't build it in a standard way (./configure && make).
@@ -31,6 +33,12 @@ PLATFORM           = powerpc-apple-darwin
 # (FP_LEADING_UNDERSCORE)
 CONFLICTS=     libelf-[0-9]*
 
+.elif ${MACHINE_ARCH} == "x86_64" && ${OPSYS} == "Linux"
+BOOTSTRAP_BUILD_MK = ${PKGDIR}/files/bootstrap-linux.mk
+BOOTSTRAP_CAPI_C   = ${PKGDIR}/files/capi-wrappers-linux-x86_64.c
+BOOTSTRAP_TARBALL  = ${DISTNAME}-boot-x86_64-unknown-linux-gnu.tar.bz2
+PLATFORM           = x86_64-unknown-linux
+
 .else
 PKG_FAIL_REASON+=      "internal error: unsupported platform"
 .endif